Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
TheMarco
Posts: 669
Registered: ‎02-19-2011
My Device: BlackBerry PlayBook 32GB
Accepted Solution

installing bar on Dev Alpha: failure 810 /var/tmp/bar_665560: cannot access member 'META-INF/MANIFEST.MF'

Can anyone tell me what in the world this means? Getting this error trying to install my signed app to my BB10 Dev Alpha device. This error is new to me.

 

 

Staff UI Prototyper (read: full-time hacker)


My BB10 apps: Screamager | Scientific RPN Calculator | The Last Weather App

Developer
Developer
LBP
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: installing bar on Dev Alpha: failure 810 /var/tmp/bar_665560: cannot access member 'META-INF/MANIFEST.MF'

Hi. Sounds mysterious. You are using Linux I assume from folder name? The file 'MANIFEST.MF' should be within your .bar file in the 'META-INF' folder, isn't it? If not something went wrong when signing. Or the .bar may not be accessable at all due to permissions when installing?


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Developer
TheMarco
Posts: 669
Registered: ‎02-19-2011
My Device: BlackBerry PlayBook 32GB

Re: installing bar on Dev Alpha: failure 810 /var/tmp/bar_665560: cannot access member 'META-INF/MANIFEST.MF'

Using Mac OS X. And I haven't done anything different than I did with earlier releases of both the WebWorks SDK and the Dev Alpha OS.

 

Also, as suggested by a friend I tried building it with the PlayBook Tablet SDK instead. That resulted in the app building and installing correctly but running it on the device gives me nothing but a blank screen. I investigated that with the remote webkit console but I didn't see anything in there that could help me either.

 

So right now with the BB10 WebWorks SDK I get this error when installing on the Dev Alpha and with the PlayBook WebWorks SDK I get an app that doesn't run. Kind of stuck here :smileyhappy:

Staff UI Prototyper (read: full-time hacker)


My BB10 apps: Screamager | Scientific RPN Calculator | The Last Weather App

Developer
Developer
LBP
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: installing bar on Dev Alpha: failure 810 /var/tmp/bar_665560: cannot access member 'META-INF/MANIFEST.MF'

Wow, really mysterious what is going on with signing. I was able to sign for PlayBook but not BB10 and now, after registering new keys I'm able to sign BB10 but not anymore for PB with them.

 

But, back to topic: did you add the "-d" for debugging within the Web Inspector and also activated the development mode on the device, hopefully you did and this isn't something can help?! So I assume another problem the RIM admins/devs here in the forum should have a closer look at if they aren't yet all on vacation. Being unable to sign for the one or the other seems to be the new favorite employment of us developers here and causing gray hairs, at least for me.


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Developer
TheMarco
Posts: 669
Registered: ‎02-19-2011
My Device: BlackBerry PlayBook 32GB

Re: installing bar on Dev Alpha: failure 810 /var/tmp/bar_665560: cannot access member 'META-INF/MANIFEST.MF'

I can actually sign with both SDKs now after some meddling around but as said, with the BB10 one it won't install and with the PB one the app won't run :smileyhappy:

Staff UI Prototyper (read: full-time hacker)


My BB10 apps: Screamager | Scientific RPN Calculator | The Last Weather App

BlackBerry Development Advisor
chadtatro
Posts: 620
Registered: ‎10-01-2009
My Device: Z10

Re: installing bar on Dev Alpha: failure 810 /var/tmp/bar_665560: cannot access member 'META-INF/MANIFEST.MF'

I troubleshot with Marco offline a little while. Here were the issues causing it to not package and deploy properly, hopefully this will help others as well in the future.

 

The problem was just a couple things.

 

Config.xml

- Missing the application ID property in the widget element

 

<widget xmlns="http://www.w3.org/ns/widgets"
      xmlns:rim="http://www.blackberry.com/ns/widgets"
        version="2.0.0.0" id="your_app_id_goes_here">

 

Index.html

- Missing a script include.  I always use Web Inspector's Network tab to make sure all my includes are loading.  It's amazing how many times I've personally done this :smileyhappy:

- Missing script include for the BB10 WebWorks JavaScript file.  Don't forget with BB10 we must include this

- Missing 'webworksready' event listener.  In Marco's case, this didn't break his app, but we must wait for this event before calling any WebWorks API's now.

 

Handy links

 

BlackBerry 10 config.xml sample

https://developer.blackberry.com/html5/documentation/code_sample_creating_a_bb_widget_config_documen...

 

BlackBerry 10 sample apps

https://github.com/blackberry/BB10-WebWorks-Samples

 

 

 

 

Chad Tetreault | App Development Consultant | BlackBerry Developer Relations | developer.blackberry.com | @chadtatro