Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
kingsha
Posts: 23
Registered: ‎07-11-2011
My Device: Beginner Developer
My Carrier: Rogers

jQuery mobile not running on BB simulators?

[ Edited ]

Hi. I am trying to make a webworks application which uses jQuery. I have successfully run it using Ripple. I am now trying to see if it works in a simulator. The application loads but jquery mobile does not take effect. I have tried using the sample jQuery demo app given here: http://supportforums.blackberry.com/t5/tkb/mobiletkbarticlepage/blog-id/browser_dev@tkb/article-id/8... but it still does not work properly. The JQM simply does not render.

 

To recreate this follow these steps:

- download the jQueryMobile.zip 9 KB (from the bottom of the link above).

- run bbwp to make a cod file like so:

C:\Program Files (x86)\Research In Motion\BlackBerry WebWorks Packager>bbwp.exe"D:\blackberry\jQueryMobile.zip" /s /o "D:\blackberry\compiles"

- open a bb simulator and click on 'File' menu and select 'Load from Java file/Load sample bb application or theme'.

- navigate to your folder (in this case it is: D:\blackberry\compiles\StandardInstall) and select the .cod file.

- now open the application (should be in menu or in 'downloads' folder)

 

As you see, the JQuery Mobile framework is not loaded. The exact same happens when I try to load my application. Any ideas???????

Please use plain text.
Contributor
kingsha
Posts: 23
Registered: ‎07-11-2011
My Device: Beginner Developer
My Carrier: Rogers

Re: jQuery mobile not running on BB simulators?

Forgot to mention that I have tried using all sorts of simulators:

os 5 - 9700 v.469

os 5 - 9700 v.680

os 5 - 9630 v.624

os 6 - 9800 v.227

 

It did not work on either of them.

 

Please use plain text.
BlackBerry Development Advisor (Retired)
jeffheifetz
Posts: 518
Registered: ‎07-18-2011
My Device: Bold
My Carrier: Rogers

Re: jQuery mobile not running on BB simulators?

Hi kingsha,

 

I packaged and build the app without changes and completely agree that in 5.0 the jquery simply does not work. However I was able to get it working as in ripple with 9800 v 227. 

 

Did you make sure you had the MDS simulator running as well since you need to download the scripts?

 



1.Please resolve your thread by clicking the "Accept as Solution" button below the post which solved your problem!
2. If any post helps you please click the button below the post(s)
Please use plain text.