Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
memehuezo
Posts: 2
Registered: ‎02-03-2011
My Device: Not Specified

my webworks only works in the simulator.. not in the phone

hi all...

 

recently begin to make a app with webwroks for visualstudio 2008.. buils my app in a BIN folder install in a BB8520 and 9700 models but dont work

 

in the simulator work fine

 

WHY???

 

 


 

Spanish:

 

Hola  a todos estoy realizando mi aplicacion en webworks para visualstudio 2008 la he compilado y he instalado la carpeta BIN en el telefono y he ejecutado el archivo.JAD... se instala y todo bien pero no funciona en los telefonos BB8520 y 9700 que son los telefonos que tendran dicha aplicación...

 

lo raro es que tambien lo he hecho con los simuladores y en este si funciona corectamente bien y todo el probela es por que no funciona ya en los telefonos realizando el mismo proceso de instalación en mi trabajo hay muchas expectativas del desarrollo de aplicacion de moviles asi que estare metido en esto por un buen tiempo

 

Gracias por su ayuda....

 

 

 

 

 

Contributor
cezeozue
Posts: 31
Registered: ‎01-06-2011
My Device: 9300

Re: my webworks only works in the simulator.. not in the phone

Did you sign it? What error message do you see on the phone?
Cheers!
Ezeozue Chidube
Seamfix Nigeria Limited (www.seamfix.com)
www.twitter.com/cezeozue
New Contributor
memehuezo
Posts: 2
Registered: ‎02-03-2011
My Device: Not Specified

Re: my webworks only works in the simulator.. not in the phone

here some example of simulator works...

 

simulatorbb1.jpg

 

in the phone install fine but dont show any error message... simply dont work

Retired
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: my webworks only works in the simulator.. not in the phone

Could it be an application permissions issue?  How are you deploying the app to a live device - using the javaloader utility, desktop manager or OTA (over the air)?

 

Try this:

1) Open the Options application from the home screen

2) Select the "Applications" screen, and find your application in the list

3) Open your application details page, and click on the "permissions" button

4) Make sure all permissions are set to 'Allow' (if not, change them, and save your changes)

5) Close out of the Options, and try re-opening your application.

 

 

 

Hope that helps,

Adam

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Developer
agungeddy
Posts: 164
Registered: ‎08-26-2010
My Device: Not Specified

Re: my webworks only works in the simulator.. not in the phone

Looks like you didnt sign it yet..

Retired
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: my webworks only works in the simulator.. not in the phone

Ah yes, that too.

 

For more info about code signing, see the following resource center article:

 

 

 

 

Cheers,

Adam

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.