Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 2
Registered: ‎02-05-2010
My Device: Curve™ 8900
My Carrier: airtel

net_rim_bb_browser_field2_api not found problem on 8900 curve?

Hi all

            i am build a basic widget to 8900 curve using  blackberry widget sdk.I installed it to physical device using javaloder.

but iam getting an error: net_rim_bb_browser_field2_api not found.

 

Please help me..

 

Mehraj R

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: net_rim_bb_browser_field2_api not found problem on 8900 curve?

Hi Mehraj,

 

BlackBerry widgets must run on a device that have the version 5.0 operating system on it.  Is your 8900 loaded with the 5.0 operating system?

 

 

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Contributor
Posts: 9
Registered: ‎03-08-2010
My Device: Curve 8320, Bold 9000
My Carrier: Telefonica

Re: net_rim_bb_browser_field2_api not found problem on 8900 curve?

[ Edited ]

Hello, Tim.

Please, some questions:

 

1. With Visual Studio 2008, what can I develop for devices with OS < 5.0 ? What can I do for the BlackBerry platform?

2. There is any other solution for create widgets in Visual Studio 2008 and runs it on a BlackBerry devices with OS < 5.0? (ie. module copy from any source).

3. If I cant to develop in Java, but with Visual Studio, what are my boundaries for develop apps for BlackBerry platform?

 

Thanks in advance.

 

Gustavo

 

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: net_rim_bb_browser_field2_api not found problem on 8900 curve?

1. With Visual Studio 2008, what can I develop for devices with OS < 5.0 ? What can I do for the BlackBerry platform?

You can do ASP.NET web development starting with 4.6.0 devices (Bold 9000) within Visual Studio.  Other than web sites, you cannot use Visual Studio for anything other than BlackBerry widgets.  We used to have an MDS Runtime technology that is now End Of Life and the tooling is no longer available for download.

 

2. There is any other solution for create widgets in Visual Studio 2008 and runs it on a BlackBerry devices with OS < 5.0? (ie. module copy from any source).

There isn't a way to run BlackBerry widgets on devices with OS < 5.0. The platform enhancements to make widgets a possibility became available in the 5.0 OS release.

 

3. If I cant to develop in Java, but with Visual Studio, what are my boundaries for develop apps for BlackBerry platform?

With Visual Studio you can build ASP.NET websites or BlackBerry Widgets.  BlackBerry widgets require OS 5.0 or higher.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Contributor
Posts: 9
Registered: ‎03-08-2010
My Device: Curve 8320, Bold 9000
My Carrier: Telefonica

Re: net_rim_bb_browser_field2_api not found problem on 8900 curve?

Hello, Tim. Thanks for your reply. I'm stuck. I'm a Visual Studio developer, and my knowlegde in Java is too little (poor). But, I need to develop a application for Blackberry with OS >= 5.0 and OS < 5.0. The same application will be used for different devices (bold 9000, Curve 8320, Curve 85XX, Javelin, etc.). This application is like a windowsform. Not a web development for go to a url from device browser: The application that I will to develop is an application, with a icon on device desktop, with options buttons and workflow, for gathering information from a ready webservices, and its information will be formatted to grids and other screen output components (textlines, listboxes, etc.).

Can it be done with Java? ONLY with java? What tools and IDE I need for download?

 

I downloaded Eclipse (Galileo), and beginners videos from Blackberry support. In some place of urls, says that this is only compatible with 3.4. Why?

 

Thanks, Tim.

 

Gustavo Barboza