Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
pandurang
Posts: 2
Registered: ‎08-22-2012
My Device: BB10
My Carrier: Blackberry
Accepted Solution

phonegap -unable to laod playbook simulator

java.io.FileNotFoundException: C:\Users\PANDUR~1\AppData\Local\Temp\
widgetGen.4725784611345739191297.tmp\cordovaExample.swf (The system cannot find
the file specified)
     [exec]     at java.io.FileInputStream.open(Native Method)
     [exec]     at java.io.FileInputStream.<init>(Unknown Source)
     [exec]     at net.rim.tumbler.file.FileManager.copyFile(FileManager.java:48
1)
     [exec]     at net.rim.tumbler.airpackager.AirPackager.run(AirPackager.java:
225)
     [exec]     at net.rim.tumbler.WidgetPackager.go(WidgetPackager.java:152)
     [exec] [ERROR]                     Air Packager exception occurred
     [exec]     at net.rim.tumbler.WidgetPackager.main(WidgetPackager.java:77)

 

load-simulator:
     [echo] This tool will not open the simulator for you
     [exec] Error: Bar file does not exist or not a file or I cannot read it: C:
\Users\pandurang\Desktop\sample\build\cordovaExample.bar

BUILD FAILED
C:\Users\pandurang\Desktop\sample\build.xml:50: The following error occurred whi
le executing this line:
C:\Users\pandurang\Desktop\sample\playbook.xml:88: exec returned: 1

Please use plain text.
Visitor
sonjz
Posts: 1
Registered: ‎08-24-2012
My Device: 9930
My Carrier: n/a

Re: phonegap -unable to laod playbook simulator

[ Edited ]
 
Please use plain text.
Developer
Developer
LBP
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: phonegap -unable to laod playbook simulator

I already answered something for PlayBook in the other thread you ask before. All you need is in your console output where it said:

 

[echo] This tool will not open the simulator for you

That means you need to start the simulator before you run the command line script to build and deploy. You also need to set up all the things for PlayBook in the "project.properties" file to get startet.

 

For the FileNotFoundException thrown when you run the command line it seems to run into an issue with your app. Can you tell us what is in your PlayBook.xml file on line 88 and in build.xml line 50 to be able to debug little bit more.

 


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Please use plain text.