Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
DirkLuys
Posts: 116
Registered: ‎02-13-2012
My Carrier: Mobistar

problems playing sound in playbook OS v2.1 beta(simulator)

I just tried one of my apps on the new Playbook OS 2.1 beta simlulator, but when a sound is started(.mp3) I get an error: "There was an error decoding this media, maybe this sound format is unsupported."

This happens with all my sounds, but they all worked in the 2.0 simulator.

The app was compiled in March, so AFAIK it has been compiled using the latest SDK.

 

Also, when I tried to visit a website with sound(eg youtube or something like one of these tracks) in the browser on the simulator, the browser crashed, I don't know wheter this is relevant to my issue or just a general shortcoming of the simulator(as it's not intended for browsing youtube etc.)

Please click the like button if my post helped you! Thank you.
Please use plain text.
BlackBerry Development Advisor
oros
Posts: 1,459
Registered: ‎04-12-2010
My Carrier: Bell

Re: problems playing sound in playbook OS v2.1 beta(simulator)

Hi there,

 

I'll give this a try on my end to see if I get the same results. The MP3 format should be supported:

http://docs.blackberry.com/en/smartphone_users/deliverables/27267/Supported_Media_Types_on_BlackBerr...

 

I haven't heard of this sort of issue yet, but I'll give it a go and let you know.


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
Please use plain text.