Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Visitor
jdecuyper
Posts: 1
Registered: ‎05-06-2010
My Device: BlackBerry 9550 Simulator

"Could not select proper transport descriptor for: http://localhost/.../index.html"

Hi!

 

This is an already already discussed topic but I could not solve it reading the answers. I have a BlackBerry environment up and running with Eclipse on my PC:

 

- no proxy is configured

- the browser in the simulator can access web resources both internally and externally

- anti-virus is disabled

 

<?xml version="1.0" encoding="utf-8" ?>
<widget xmlns="http://www.w3.org/ns/widgets" xmlns:rim="http://www.blackberry.com/ns/widgets" version="1.0.0">
	<name>Test</name>
	<description>Test</description>
	<author href="http://jdecuyper.com">jdecuyper</author>
	<content src="http://localhost/blackberry/index.html" />
	<rim:loadingScreen backgroundColor="#f7e7c6"/>
  	<access uri="http://localhost/blackberry/" subdomains="true">
  		<feature id="blackberry.system" />
		<feature id="blackberry.identity" />
	</access>
</widget>

 

For some unknown reason, the widget is not able to retrieve a page from my local IIS but it 

has no problem retrieving pages from a remote IIS. I have already double checked all IIS properties 

but could not find anything. 

 

 

Error message: 

 

"Could not select proper transport descriptor for: http://localhost/blackberry/index.html"

 

Environment:

 

- Smartphone Simulator 2.13.0.95

- Windows Vista Professional

 

Thanks a lot for your help!

Please use plain text.
Retired
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: "Could not select proper transport descriptor for: http://localhost/.../index.html"

What happens if you give the fully qualified domain name as it is specified on your LAN for your machine instead of localhost.  In some environments we have seen that there can be a problem resolving localhost.

 

 

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
Visitor
asethia
Posts: 1
Registered: ‎07-02-2010
My Device: 9905

Re: "Could not select proper transport descriptor for: http://localhost/.../index.html"

Any update on this... I am also getting same error while accessing localhost.

Please use plain text.
Retired
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: "Could not select proper transport descriptor for: http://localhost/.../index.html"

 


asethia wrote:

Any update on this... I am also getting same error while accessing localhost.


Have you tried to use the fully qualified domain name for your computer instead of localhost?

 

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
Retired
mwoolley
Posts: 571
Registered: ‎06-25-2010
My Device: Z10

Re: "Could not select proper transport descriptor for: http://localhost/.../index.html"

I have the same problem but working with a local Apache web server rather than IIS. I have however solved the problem.

 

Here's how:

 

- first check whether or not you can access the problem URL from a desktop web browser. If you can then read no further.... you have a different problem. If you cannot then your problem is probably like mine and it concerns the web server configuration.

 

Apache and other web servers allow you to bind to a specific IP and port. Any other address, even if it corresponds to the same machine, will not work. So in the Apache web server config (httpd.conf) I have:

 

Listen 172.20.119.200:80

 

172.20.110.200 is the IP of my laptop's ethernet interface and to all intents and purposes is synonymous with localhost.

 

Consequently the following URL can be reached successfully:

 

http://172.20.119.200

 

The following "equivalent" URL however will not be served by the web server:

 

http://127.0.0.1

 

In IE you get "Internet Explorer cannot display the web page".

 

In a Web Works app trying to access http://127.0.0.1 you get "Could not select proper transport selected...."

 

Hope this helps.

--------------------------------------------------------------------------------------------
Feel free to press the like button on the right side if you liked my attempts to help :-)
And please mark posts as solved if you think I found the solution or set you on its path. Thanks!
Follow me on Twitter: @mdwrim
Please use plain text.
Contributor
kaansengul
Posts: 21
Registered: ‎10-28-2011
My Device: Bold 9700

Re: "Could not select proper transport descriptor for: http://localhost/.../index.html"

Please use plain text.