Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
Posts: 14
Registered: ‎09-27-2013
My Device: Developer
My Carrier: Vodafone

"file cannot be found in the list of packaged files" error while setting splash screen in my bb10

I am working on a blackberry 10 webworks application. I want to set splash screen that supports 3 different resolution (720x720, 720x1280, 768x1280 pixels).

The below is my application folder structure.
[ATTACH=CONFIG]223250[/ATTACH]

Here I have one folder named "[B]locales[/B]" in which i kept three splash images for the resolution accordingly. eg: locales->(splash-720x720.png, splash-720x1280.png, splash-768x1280.png).

In my config.xml file I have added this line:

<widget>
<rim:splash src="splash-720x720.png"/>
<rim:splash src="splash-720x1280.png"/>
<rim:splash src="splash-768x1280.png"/>

</widget>

It has been told that blackberry will select the splash images from the locales folder. But when i run my app I get this error:

[B]Oh Snap! Build request failed with message: [ERROR] Error: Attribute image: file cannot be found in the list of packaged files: splash-720x720.png [ERROR] Native Packager exception occurred [ERROR] Error: Attribute image: file cannot be found in the list of packaged files: splash-720x720.png [ERROR] Native Packager exception occurred[/B]

pls help me

Retired
Posts: 1,561
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: "file cannot be found in the list of packaged files" error while setting splash screen in my bb10

[ Edited ]

Hi there, can you please try specifying the full folder names? Example:

<rim:splash src="locales/splash-720x720.png"/>
<rim:splash src="locales/splash-720x1280.png"/>
<rim:splash src="locales/splash-768x1280.png"/>

I haven't heard that regarding the locales folder; it should just reference the direct paths you specify. Is there online documentation that states this?

The application folder structure image did not come through, if you still see issues, could you please re-attach it?

 

EDIT: I just wanted to follow-up on this, have you been able to give the above a shot?


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.