Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
abhinesh_rao
Posts: 4
Registered: ‎02-21-2010
My Carrier: 270887

"net_rim_bb_browser_field2_api" not found error

Hi I am running my blackberry simulator on my Virtual machine which is 32 bit Windows XP OS (my host OS is 64-bit Windows 7 OS.

 

When I compile my widget and try to run it on Eclipse using Blackberry 9000 simulator I get an error message saying  "net_rim_bb_browser_field2_api" not found ..

 

So please can anyone help me on this

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,702
Registered: ‎10-16-2008
My Carrier: Rogers

Re: "net_rim_bb_browser_field2_api" not found error

[ Edited ]

Do you have a 9000 simulator that has the BlackBerry OS version 5.0 on it?  The BrowserField2 api requires the 5.0 operating system

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
New Contributor
abhinesh_rao
Posts: 4
Registered: ‎02-21-2010
My Carrier: 270887

Re: "net_rim_bb_browser_field2_api" not found error

Hi Tim,

 

When I check the "about" option in the "help" option of the simulator it shows me

 

About - BlackBerry Smartphone Simulator
---------------------------------------
BlackBerry Smartphone Simulator 2.10.0.123
Special thanks to the wxWidgets, C++ Boost, and PortAudio projects.

 

Also can you please give me the link wherein I can download the balckberry simulator with version 5.0 OS.

 

Thanks a lot for your help

 

Regards,

 

Abhinesh Rao

MS in CS

Georgia Tech

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,702
Registered: ‎10-16-2008
My Carrier: Rogers

Re: "net_rim_bb_browser_field2_api" not found error

You can download the latest 5.0 simulators for the desired model of smartphone here:

 

http://na.blackberry.com/eng/developers/resources/simulators.jsp

 

Cheers

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
New Contributor
abhinesh_rao
Posts: 4
Registered: ‎02-21-2010
My Carrier: 270887

Re: "net_rim_bb_browser_field2_api" not found error

[ Edited ]

Hi Tim,

 

Thanks for the link. I installed the 9500 simulator having OS version 5.0. Now, I had previously downloaded " the BlackBerry Web Development Plug-in for Eclipse 1.0 (including Eclipse IDE) package" from the f...

 

 

http://na.blackberry.com/eng/developers/browserdev/eclipse.jsp

 

But it by default has the 9000 simulator with OS version 4.6. So now, how do I replace this simulator with the one I just downloaded(ie 9500 simulator), so that my applications could be run on the 9500 simulator.

 

Also, the Internet does not work on the recently downloaded 9500 simulator. So kindly suggest a solution for the same.

 

Thanks and regards,

 

Abhinesh Rao

MS in CS

Georgia Institute of Technology

 

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,702
Registered: ‎10-16-2008
My Carrier: Rogers

Re: "net_rim_bb_browser_field2_api" not found error

In the preferences area of Eclipse you will find a BlackBerry section.  In here you can chose the newly installed simulator to be used when running your website.

 

The version 2.0 Beta of the Eclipse Web plug-in will allow you to also build BlackBerry Widgets.  The 1.0 version is just for making building websites easier.

 

When you run the simulator standalone it will not have a connection to the internet.  All connections from the Device Simulator go through an MDS Simulator.  When you run the device simulator through Eclipse, it automatically launches and runs an MDS for you in the background.

 

If you want to use the simulator standalone and require a network connection, you will need to download the MDS simulator to run and act as a Proxy for the device simulator.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.