Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Highlighted
New Developer
Posts: 6
Registered: ‎09-15-2008
My Device: Not Specified
Accepted Solution

some sites work, some give a 400 error

cnn.com, google.com, etc work.  My website doesn't.

 

Is there something I need to do?  It's an asp.net 2.0 application.  I'm using the 7100g simulator.  It works fine in the 8130 simulator.  I'm using MDS 4.1.4.  I could not get the other MDS to work, I installed the JDE 1.5, but the other MDS installer will not install.  Possibly one MDS version works with some simulators, and not others.....but in the 7100g simulator...some sites work, and mine does not.

 

In the end, I'm trying to figure out javascript compatibility.  I'm able to change the displayed text in text boxes in the simulator 8130 (and button text using the .value for both), but only the button text is showing up changed on my wife's phone (version and type I'll have to run down again).  In the end, I wanted to figure out what phones my website is compatible on (at least one simulator so far Smiley Sad ) - and which ones it is not.  And if upgrades help.  I was hoping the simulator was the best route.

 

Going forward, I was also wanting to figure out if the blackberry simply doesn't like some page formatting, etc, and if there is a mobile tag or something that comes down to tell the BB browser this is a page worth grabbing?

 

Guru I
Posts: 19,012
Registered: ‎07-29-2008
My Device: Passport, Playbook, 9320BES
My Carrier: Bouygues _ SFR

Re: some sites work, some give a 400 error

hello,

can you give the url of the website that does not work ?
does the site validate with the HTML validator and the css validator from the W3C ?

http://validator.w3.org/

 

http://jigsaw.w3.org/css-validator/

 

 for websites,if they are coded in respects to HTML4 or XHTML, and good css, it should render quite well on any browser including the ones on handheld devices.

 

 otherwise, you can search for a directory of websites. Usually, when a website has an url that matches the following, it's fine :




The search box on top-right of this page is your true friend, and the public Knowledge Base too:
Developer
Posts: 1,415
Registered: ‎07-30-2008
My Device: Not Specified

Re: some sites work, some give a 400 error

IF it is your own server, don't forget things like mime type and response headers. I'm not

sure exactly what a 400 is but you can get odd results if this isn't right.

 

AFAIK, 400 is a bad request being returned from your server. Presumably you are examining request

headers and determining the device is unsuitable.

 

http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html

 

http://www.ietf.org/rfc/rfc1945.txt

 

so, you want to know what your server is objecting to?

New Developer
Posts: 6
Registered: ‎09-15-2008
My Device: Not Specified

Re: some sites work, some give a 400 error

I found a path that works.  It's www.handtop.com, hosted through webhost4life.com.  The handtop.com doesn't work, but site414.mysite4now/huskersam/site1 does work through the simulator.

 

I'm not sure it's just a path mangle or what exactly - but handtop.com is working through my blackberry, just not he simulator.

 

Probably some network redirect that is getting mangled, i'm not sure, but it's functional for me now.

 

I've isolated the main problem I'm chasing, and that is that I'm able to use obj.value to change the contents of textareas in some blackberries, but not in the 8830.  I'll start a new topic on this.  I was hoping to be able to update some type of multiline field - it doesn't need to be editable, with javascript.  I was using textareas, but now I've found they dont' work.

 

Thanks for your replies.