Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
jeremygwa
Posts: 4
Registered: ‎10-23-2011
My Device: n/a
My Carrier: n/a

the new WebWorks Signing is messed up

All,

 

I follow the instructions using blackberrys online how-to, but the SignatureTool.jar always alerts that i do not have a private key in the /bin, so i have to create it. next I follow the instructions online, but i cannot find the

"Registration PIN" fields and all the other fields, and when i go to add cod files, they do not show up.

 

Whats up with this?

your help is appreciated. Thankyou

jeremy

Please use plain text.
BlackBerry Development Advisor (Retired)
jeffheifetz
Posts: 518
Registered: ‎07-18-2011
My Device: Bold
My Carrier: Rogers

Re: the new WebWorks Signing is messed up

Hi jeremygwa,

 

Please check out the signing instructions here -  https://bdsc.webapps.blackberry.com/html5/documentation/ww_publishing/signing_your_app_1866989_11 and follow them.

If you have any questions afterwards feel free to follow-up



1.Please resolve your thread by clicking the "Accept as Solution" button below the post which solved your problem!
2. If any post helps you please click the button below the post(s)
Please use plain text.
New Contributor
jeremygwa
Posts: 4
Registered: ‎10-23-2011
My Device: n/a
My Carrier: n/a

Re: the new WebWorks Signing is messed up

ok, I was able to install the keys sent from blackberry, into my system

 

but when i try compiling my app to my device, using 'ant load-device', the signature tool asks me to sign the cods, but it keeps on telling me, that i do not have a password bigger than 8 charactors, though it is more than 8 charactors long.

changing the password does nothing.

Please use plain text.
BlackBerry Development Advisor (Retired)
jeffheifetz
Posts: 518
Registered: ‎07-18-2011
My Device: Bold
My Carrier: Rogers

Re: the new WebWorks Signing is messed up

Can I just confirm a few things

 

1) We're speaking about signing for smartphone correct?

2) Are you entering the password manually into the tool or through the build script?

3) Are you using Mac or Windows?

4) The password you're entering is for your private key and NOT the PIN from your downloaded keys



1.Please resolve your thread by clicking the "Accept as Solution" button below the post which solved your problem!
2. If any post helps you please click the button below the post(s)
Please use plain text.
New Contributor
jeremygwa
Posts: 4
Registered: ‎10-23-2011
My Device: n/a
My Carrier: n/a

Re: the new WebWorks Signing is messed up

yes i am signing for smartphone

yes i have entered a password in the properties file......that may be the problem.

Please use plain text.
Contributor
leocrawf
Posts: 47
Registered: ‎06-06-2011
My Device: bolt2
My Carrier: digicel jamaica

Re: the new WebWorks Signing is messed up

I am having the dame problem. Each time I try i get the dame password must be greater than 8 charachter issue. I have changed the password but nothing happens. What am I doing wrong?

Please use plain text.
BlackBerry Development Advisor (Retired)
jeffheifetz
Posts: 518
Registered: ‎07-18-2011
My Device: Bold
My Carrier: Rogers

Re: the new WebWorks Signing is messed up

Can you guys please test removing the password from the build script and having the signing tool ask for it?



1.Please resolve your thread by clicking the "Accept as Solution" button below the post which solved your problem!
2. If any post helps you please click the button below the post(s)
Please use plain text.
BlackBerry Development Advisor (Retired)
jeffheifetz
Posts: 518
Registered: ‎07-18-2011
My Device: Bold
My Carrier: Rogers
Please use plain text.