Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
squished18
Posts: 289
Registered: ‎10-17-2008
My Device: Torch 9800
My Carrier: Rogers

unable to open Web Inspector on 9810

Hello,

 

When I try to run Web Inspector on either the browser or on a standalone app, nothing happens.

 

I am connected to WiFi on the device.

 

In the browser, I have checked "Enable Developer Tools". When I select "Developer Tools" -> "Enable Web Inspector" from the menu, nothing happens.

 

For the standalone app, I have tried packaging it both using the "-d" option and the "/d" option. In both cases, when I load up the app I do not get a Web Inspector pop-up window.

 

Web Inspector does work for the standalone app within the simulator. I am able to successfully connect Web Inspector to the app when it is running in the simulator. But I don't get any Web Inspector response from the handheld.

 

Any ideas?

 

Thanks,

 

feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
Please use plain text.
BlackBerry Development Advisor (Retired)
jeffheifetz
Posts: 518
Registered: ‎07-18-2011
My Device: Bold
My Carrier: Rogers

Re: unable to open Web Inspector on 9810

What version of 7.0 is the device running?

 

Can you find out the IP of the phone (perhaps from a home router) and see if you navigate there does anything happen?



1.Please resolve your thread by clicking the "Accept as Solution" button below the post which solved your problem!
2. If any post helps you please click the button below the post(s)
Please use plain text.
Developer
squished18
Posts: 289
Registered: ‎10-17-2008
My Device: Torch 9800
My Carrier: Rogers

Re: unable to open Web Inspector on 9810

I'm using 7.0.0.540.

 

I did try navigating to the IP trying both port 1337 and 1338, but do not get any response.

 

feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
Please use plain text.
BlackBerry Development Advisor (Retired)
jeffheifetz
Posts: 518
Registered: ‎07-18-2011
My Device: Bold
My Carrier: Rogers

Re: unable to open Web Inspector on 9810

[ Edited ]

***Edited***

 

This works fine on the simulator with the same OS, will try on a real device tomorrow. Its weird you don't get any pop-up at all, especially from the web browser.



1.Please resolve your thread by clicking the "Accept as Solution" button below the post which solved your problem!
2. If any post helps you please click the button below the post(s)
Please use plain text.
Visitor
composer47
Posts: 1
Registered: ‎02-21-2012
My Device: torch 9810
My Carrier: AT&T

Re: unable to open Web Inspector on 9810

Is there a fix for this? I have the exact same problem. I'm running a Torch 9810 on OS 7.0.0.261.
Please use plain text.
Developer
squished18
Posts: 289
Registered: ‎10-17-2008
My Device: Torch 9800
My Carrier: Rogers

Re: unable to open Web Inspector on 9810

No, I never did get this issue resolved. I've just had to do all my debugging within a simulator first.

 

feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
Please use plain text.