Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
s9ik3
Posts: 11
Registered: ‎11-19-2009
My Device: Not Specified

upload ajax + jquery

hi , i build widget with jquery + ajax (i ve used this tutorial for example http://webdeveloperplus.com/jquery/ajax-multiple-file-upload-form-using-jquery/ ) but widget don't work :smileysad: can help me ? tnks

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: upload ajax + jquery

Can you get the same example to work in the generic BlackBerry Browser... 

 

Your issue could be around either a JQuery incompatibility with the BlackBerry Browser, or a white listing issue.

 

Have you whitelisted the domain you are trying to upload to in the <access> elements of your config.xml file?

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
Developer
davidmccormack
Posts: 168
Registered: ‎11-01-2008
My Device: Galaxy S II
My Carrier: Meteor (Ireland)

Re: upload ajax + jquery

Just to add my 2 cents worth...

 

The only funnies I've seen with jquery on the BB brower are with some of the animation effects that you can use to make divs slide or fade into view. I haven't had any issues at all with the basic 'selector' stuff, AJAX methods, etc. The jquery.js file is pretty big though and it takes the BB browser a second or so to parse it, even on the simulator. I haven't been able to test my widget on a physical device yet but I'm expecting it will be even slower - hopefully not too slow. 

Please use plain text.
New Developer
britishturbo
Posts: 23
Registered: ‎11-05-2009
My Device: Not Specified

Re: upload ajax + jquery

I currently have a bunch of ajax and jquery running on the widget platform... it works very very nicely...

 

From looking at that example I would guess the problem is it uses a hidden ifram to do the upload, and iframes are not working ont he widgets yet... :smileywink:

Please use plain text.