Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
deedubbu
Posts: 35
Registered: ‎07-07-2011
My Device: Torch
My Carrier: AT&T

viewport height meta tag requirement for OS 6 simulators

I spent almost a day trying to figure out why my application was no longer working in OS 6 simulators so thought I would post here in hopes of saving others the frustration I faced......

 

Once I updated to WebWorks SDK 2.2 I began seeing an odd behavior in OS 6 simulators (torch 9800 specifically).  When trying to launch my app, it would load and then almost immediately close like it was crashing.  My app worked fine on OS 5 and 7 simulators and on an actual OS 6 device (torch 9800).  After a bunch of debugging and playing around with things I finally discovered that if I specify viewport "height" equal or greater to the device-height then the app worked correctly in the simulator.  Specifying a viewport height less then the device-height for some reason causes the OS 6 simulator to choke and close the app.

 

Note, that the application works fine in OS 6 simulator without height specified if built with an older version of the WebWorks SDK.  I only see the issue with the 2.2 version.  Also, the issue is only with the "height" parameter.  The application works fine in the OS 6 simulator if the "width" parameter is not specified.

Please use plain text.