Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
youngjun
Posts: 40
Registered: ‎09-03-2008
My Device: Not Specified

web inspector not working on 7.1 device?

I have a 9930 smartphone 7.1 Bundle 457(V7.1.0.173 platform 5.1.0.137).

I've tried browser Enable Developer Tools. When I browser a web page, I do see Developer Tools->Enable Web  Inspector, but when I click on it, I don't see any popup for IP address.

 

I also tried to find the device IP address via http://whatismyip and use desktop browser to go to http://<IP>:1337 and can't load the page.

 

The same situlation ocurrs on my other phone 9900 7.1 Buldle 1310(V7.1.0.391 platform 5.1.0.319).

Is this hardware issue or something I missed?

 

Thanks,

 

June Jorgensen

Please use plain text.
Developer
nunodonato
Posts: 313
Registered: ‎03-28-2012
My Device: Curve 9360, Playbook, BB10 Dev Alpha

Re: web inspector not working on 7.1 device?

Hi!
When you package you app, you need to pass the -d flag to bbwc to enable debugging via the inspector.
After that, if you enabled it in the device browser, you'll see the popup with the URL when you start the app.

Happy coding!
Nuno
theBBthing.wordpress.com - my BlackBerry development blog: news, tips and tutorials
bitoutsidethebox.com - re-imagining digital solutions


Please use plain text.
Developer
youngjun
Posts: 40
Registered: ‎09-03-2008
My Device: Not Specified

Re: web inspector not working on 7.1 device?

I think we are talking about two different thing.

 

1. One is browsing web application in blackberry browser.

2. running webworks application which does not require enabling developer tool in browser and instead requires -d option at bbwp command. 

 

In my situation, for case 1, I've enabled developer tool and clicked web inspector menu while in a web page in browser, but no IP address popsup.

 

For case 2, I've  packaged the kitchSink sample code with webworks SDK 2.3.1 with -d option and run the app on my 7.1 device. When I start the application, I don't see the IP popup either as supposed to see.

 

June

Please use plain text.
Regular Contributor
tububerry
Posts: 51
Registered: ‎05-25-2012
My Device: Bold 9930

Re: web inspector not working on 7.1 device?

I am having the same exact situation.

 

I am using alerts coz no IP address pops up.

 

Please use plain text.
Developer
youngjun
Posts: 40
Registered: ‎09-03-2008
My Device: Not Specified

Re: web inspector not working on 7.1 device?

Can anyone advise whether it is firmware related? Do I have an option such as upgrade/downgrade to a different version to make it work?

 

Thanks,

 

June

Please use plain text.
Retired
mimendoza
Posts: 64
Registered: ‎06-04-2012
My Device: Blackberry Z10

Re: web inspector not working on 7.1 device?

Hi, 

 

Are you on a wi-fi network or on mobile data? Remote Web Inspector works over wi-fi so please ensure that you are on a wi-fi connection. As soon as you are connected and enable Web Inspector in the app, the pop up should appear.

 

- Michelle

 

----------------------------------------------------------------------------------
- Did this post help solve the issue? Click on "Accept as Solution"
- Was the content of this post helpful? Please give it a "Thumbs Up"

developer.blackberry.com
@BlackBerryDev
Please use plain text.
Developer
youngjun
Posts: 40
Registered: ‎09-03-2008
My Device: Not Specified

Re: web inspector not working on 7.1 device?

The wifi is definitely turned on. I also followed some suggestion on the forum to turn off the network service and only leave wifi on. I got the same error with the network service on and off.

 

June

Please use plain text.