Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

New Contributor
Posts: 4
Registered: ‎04-18-2011
My Device: Dont hava a device yet
My Carrier: none

Air App crash right after install

[ Edited ]

I am having a really strange issue.


I have made several apps for BB Playbook and successfully deployed them to the market. But suddenly I am not able to build a simple app anymore.



- I made a new AS mobile project in FB 4.6 and did nothing. So, no code just an empty project

- I changed the blackberry-tablet.xml to:





   <!--  Name of author which is used for signing. 

         Must match the developer name of your development certificate -->

   <author>Gryphon Interactive</author>


   <!--  Unique author ID assigned by signing authority. Required if using debug tokens -->

   <!-- <authorId>ABC1234YjsnUk235h</authorId> -->


   <!--  The category where the application appear. Either core.games or core.media-->

   <!-- <category>core.games</category> -->


   <!--  The icon for the application which should be 86x86 -->





   <!--  The splashscreen that will appear when your application is launching. Should be 1024x600. -->

   <!-- <splashscreen>helloworld-splash.png</splashscreen> -->


   <!--  The permissions requested by your application. -->


   <!-- <permission>record_audio</permission> -->

   <!-- <permission>read_geolocation</permission> -->

   <!-- <permission>use_camera</permission> -->




   <!-- <permission>set_audio_volume</permission> -->



   <!--  Fourth digit segment of the package version. First three segments are taken from app 

   description versionNumber tag. Must be an integer from 0 to 2^16-1 -->




Also nothing special I gues?


- Than I filled in a few vars of main-app.xml (id, filename, name, versionnr (0.0.2), label and copyright)

- I compiled the project to a release version and digitaly signed it with FB. This all goes fine and FB sais I'm authorized

- Finally I put the .bar on my playbook with GraphicalAid. Logs:


Result: Info: Sending request: Install and Launch Info: Action: Install and Launch Info: File size: 26431 Info: Installing Main.gYABgCmrUHK9DcE6lKeFhVM9O00... Info: Processing 26431 bytes Info: Progress 100%... actual_dname::Main.gYABgCmrUHK9DcE6lKeFhVM9O00 actual_id::gYABgCmrUHK9DcE6lKeFhVM9O00 actual_version:: result::success Info: Launching Main.gYABgCmrUHK9DcE6lKeFhVM9O00... result::14856225 Info: done


Its installs correctly and shows up on the playbook. But when I launch it, it shows the splash screen and crashes. Immediately.


So could anybody please explain me what I'm doing wrong or overseeing?




- I have rebooted the device because I read somewhere it could help, still no luck.

- I have uninstalled the app, updated the playbook to latest version and reinstalled the app. Still no luck.


I think it has something to do with the certificates, because the project code is nothing special. But than I find it extremely weird that I can digitaly sign it using FB and install it using graphical aid without any errors. Anybody has a clue?..



Ok, I have figured it out. The problem was the SDK. When I compile my test project with Flex 4 SDK, it works. But when I compile the same project with flex4 & Air 3.2 it crashes. Logical because the playbook doesn't support air 3.2 at the moment.. Please guys of RIM Bring Stage3D to the Playbook. You will need it!

New Contributor
Posts: 2
Registered: ‎06-19-2012
My Device: Playbook
My Carrier: Telstra

Re: Air App crash right after install

yeah i agree.. all the latest flash games use the Starling Framework. and for that stage3d is needed. c'mon RIM, catch up!