Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
Posts: 104
Registered: ‎04-15-2012
My Device: BlackBerry PlayBook with OS 2.0
My Carrier: N/A

Any idea why I'm getting this?

Hello all!

 

Please forgive me if I'm posting this at the wrong section as this is my first post in BlackBerry Support Forums (and I'm new to forums in general).

 

Anyway, here's the problem: I got interested in developing for PlayBook and I set-uped my PC with Tablet OS SDK and Adobe Flash Builder 4.6 and the PlayBook simulator. And for a start I copied the whole code listing from the BlackBerry Getting Started guide for Adobe AIR. But, it shows 2 imports as not available. The imports:

 

import qnx.dialog.DialogButtonProperty;
import qnx.dialog.PromptDialog;
import qnx.display.IowWindow;
import qnx.fuse.ui.buttons.LabelButton;
import qnx.fuse.ui.text.Label;

 

Only the last two imports show errors (says they cannot be found).

 

So anyone have any idea why this is? Maybe I'm overlooking some small thing but can't figure out what this is..

My BlackBerry 10 apps: Roshnal Lihinikadu
Lots more coming up!
Developer
Posts: 350
Registered: ‎01-21-2011
My Device: Curve 8900 (Personal) / Bold 9650 (Work)
My Carrier: Regional

Re: Any idea why I'm getting this?

Are you using the latest SDK?

Developer
Posts: 104
Registered: ‎04-15-2012
My Device: BlackBerry PlayBook with OS 2.0
My Carrier: N/A

Re: Any idea why I'm getting this?

Yep, I only downloaded the required stuff about 6-7 days ago..

My BlackBerry 10 apps: Roshnal Lihinikadu
Lots more coming up!
Developer
Posts: 350
Registered: ‎01-21-2011
My Device: Curve 8900 (Personal) / Bold 9650 (Work)
My Carrier: Regional

Re: Any idea why I'm getting this?

Make sure you right click the project in the package explorer window (off to the left) and under actionscript build \ blackberry tablet. Make sure all the boxes for the libraries are checked
Developer
Posts: 104
Registered: ‎04-15-2012
My Device: BlackBerry PlayBook with OS 2.0
My Carrier: N/A

Re: Any idea why I'm getting this?

I have "Add Platform Specific Libraries To Project" checked.. Other than that, I do not see any specific libraries to check/uncheck.

My BlackBerry 10 apps: Roshnal Lihinikadu
Lots more coming up!
Developer
Posts: 350
Registered: ‎01-21-2011
My Device: Curve 8900 (Personal) / Bold 9650 (Work)
My Carrier: Regional

Re: Any idea why I'm getting this?

[ Edited ]

Make sure under Window --> Preferences --> Flash Builder --> Target Platforms --> BlackBerry Tablet OS

The checkbox for "latest SDK" is checked. You don't want it pointing to something pre 2.0, as 2.0 brings the fuse components in.

 

If this doesn't work I am not sure what the issue would be then. I would suggest exiting Flash Builder and attempting to reinstall the SDK as they import just fine for me. Make sure the "Integrate with Flash Builder" option is checked if you reinstall the SDK.