Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
Posts: 889
Registered: ‎08-31-2009
My Device: 9530, 9630, 9800, 8530, 9900, 9810, 9930, PlayBook, Dev Alpha
My Carrier: Verizon

Re: BBM Social Platform ANE

The github page referes to "two library files" yet I can only find "bbmsp-ane.ane" is there a .swc file that I am not aware of?


Read my thoughts on BlackBerry Development at news.ebscer.com
Developer
Developer
Posts: 1,123
Registered: ‎02-10-2009
My Device: 8130 / 8350 / 9530 / 9550 / 9850 / PlayBook
My Carrier: Verizon

Re: BBM Social Platform ANE

Yes, there is a SWC in the BBM-ane/bin folder......you need to reference it so it doesn't throw errors about undefined classes, but its packaged inside of the ANE
Developer
Posts: 889
Registered: ‎08-31-2009
My Device: 9530, 9630, 9800, 8530, 9900, 9810, 9930, PlayBook, Dev Alpha
My Carrier: Verizon

Re: BBM Social Platform ANE

If it is packaged inside of the .ane than presuably I don't need to refereance it seperatly?

Also on github there is no BBM-ane/bin folder. My attempts to recompile the project myself failed, but that is most likely just me doing something stupid...


Read my thoughts on BlackBerry Development at news.ebscer.com
Highlighted
Developer
Developer
Posts: 1,123
Registered: ‎02-10-2009
My Device: 8130 / 8350 / 9530 / 9550 / 9850 / PlayBook
My Carrier: Verizon

Re: BBM Social Platform ANE

If you don't reference the SWC then it gives warnings about the imports and function names, but still compiles (if I remember correctly). I'll check the files shortly and make sure everything is there.
Developer
Posts: 889
Registered: ‎08-31-2009
My Device: 9530, 9630, 9800, 8530, 9900, 9810, 9930, PlayBook, Dev Alpha
My Carrier: Verizon

Re: BBM Social Platform ANE

Everything actually compiles ok for me. The problem is that once the app is lauched it will automatically shut down. At this point I am not actually calling any of the code, but just referencing the extension in the .xml file.


Read my thoughts on BlackBerry Development at news.ebscer.com
Developer
Developer
Posts: 1,123
Registered: ‎02-10-2009
My Device: 8130 / 8350 / 9530 / 9550 / 9850 / PlayBook
My Carrier: Verizon

Re: BBM Social Platform ANE

Is it your personal application that is shutting down? Did you add the bbm and native permissions to your applications xml file? If you're debugging it using the actual device and have the NDK installed you can use the remote explorer (I think that's name) and go to your applications directory and its logs to see what the error is that's causing it to close. You can find it under sandboxes > (your app).debug > logs. The air-log will give you the errors that AIR is putting out and log shows the native errors.
Developer
Developer
Posts: 1,123
Registered: ‎02-10-2009
My Device: 8130 / 8350 / 9530 / 9550 / 9850 / PlayBook
My Carrier: Verizon

Re: BBM Social Platform ANE

I figured out why some of the files were missing. I didn't realize that git excluded certain files from upload by default. I changed the name of the SWC folder and its now included. It also excludes project files by default. I didn't add those back in but I can if anyone would like me to.
Developer
Posts: 889
Registered: ‎08-31-2009
My Device: 9530, 9630, 9800, 8530, 9900, 9810, 9930, PlayBook, Dev Alpha
My Carrier: Verizon

Re: BBM Social Platform ANE

Turns out my problem is actually something else.

 

I am currently unable to attach any ANE's at all to any of my projects...


Read my thoughts on BlackBerry Development at news.ebscer.com
Developer
Developer
Posts: 1,123
Registered: ‎02-10-2009
My Device: 8130 / 8350 / 9530 / 9550 / 9850 / PlayBook
My Carrier: Verizon

Re: BBM Social Platform ANE

What is happening when you try to attach an ANE?
Developer
Posts: 889
Registered: ‎08-31-2009
My Device: 9530, 9630, 9800, 8530, 9900, 9810, 9930, PlayBook, Dev Alpha
My Carrier: Verizon

Re: BBM Social Platform ANE

The app crashes on launch whenever I attach an ANE. I made a simple hello world app, and a hello world ANE (which I don't even call) in order to test this and I still get the same problem. Intersetingly I can still use the prepackaged QNXDevice.ane but nothing else works. In case it makes a difference, I should note that I am doing this from the command line...


Read my thoughts on BlackBerry Development at news.ebscer.com