Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
New Contributor
Posts: 6
Registered: ‎10-26-2010
My Device: Not Specified

Cannot Connect to Device

Hi,

When I try to complie and debug 'AIRHelloWorld' I keep recieving a cannot connect to device error.I have pinged the VM and it returns with 4 out of 4 packets sent with a latency of 0ms. Maybe that means it's not connected but any help would be grately appreciated.

 

Thank You

Contributor
Posts: 35
Registered: ‎10-25-2010
My Device: Not Specified

Re: Cannot Connect to Device

Some firewall configuration may block other ports (from the host).

Are you running VPN or any other corporate firewalls can be on the way?

What platform?

New Contributor
Posts: 6
Registered: ‎10-26-2010
My Device: Not Specified

Re: Cannot Connect to Device

[ Edited ]

Running Win 7 64bit Home Edition

 

Using VMplayer, usually when apps require internet access the windows firewall pops up asking for permissions, yet it didn't for VMPlayer or Adobe Flash Builder 4...

 

Maybe I need to add permissions?

Contributor
Posts: 35
Registered: ‎10-25-2010
My Device: Not Specified

Re: Cannot Connect to Device

Do you have firewall on the router (if you have local network)? Try to disable all firewalls to see if helps. Tools need port 443 on target (https)

New Contributor
Posts: 6
Registered: ‎10-26-2010
My Device: Not Specified

Re: Cannot Connect to Device

Well I'm on my campuses internet therefore I don't have access to the routers, but I checked all my firewall privlages, and both Flash Builder and VMPlayer have interent access.

Developer
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Cannot Connect to Device

Have you checked to see that Development Mode is turned on and that you're using that IP address and not the one under About?

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
New Contributor
Posts: 6
Registered: ‎10-26-2010
My Device: Not Specified

Re: Cannot Connect to Device

Yes many times, I have it enabled and in the screen with the hammer it says development mode is on

Contributor
Posts: 35
Registered: ‎10-25-2010
My Device: Not Specified

Re: Cannot Connect to Device

Try 

telnet <your_device_ip> 443

 

what do you see?

 

Btw how did you configure vmware NAT or Bridged? Try changing it maybe?

Developer
Posts: 93
Registered: ‎10-22-2009
My Device: Not Specified

Re: Cannot Connect to Device

hi,

 

Im experiencing same problem when trying to connect to the playbook simulator via flash builder 4.0.1. I get ....

Error: Cannot connect to target: Connection timed out: connect

I have spent nearly 2 days on this sdk and am still not able to develop.

I have tried allsuggestions on this thread like disabling firewall and changing network type in vmware player.

Regards

Alex

New Contributor
Posts: 6
Registered: ‎10-26-2010
My Device: Not Specified

Re: Cannot Connect to Device

@AlexW

 

I have done exactly as stated by everyone here, including changing from bridged to NAT, and it hasn't worked.