Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

New Contributor
Posts: 9
Registered: ‎04-28-2010
My Device: 9950
My Carrier: at&t

Cannot deploy to device any more

Hi folks,


I've been deploying to my Tablet using the command below for some time, and now

it is failing. I'm guessing something changed on my tablet or environment, but I'm not

able to track down what the issue is. Any pointers / suggestions appreciated.


What I've tried:

1) Verified ip address of tablet.

2) Restarted tablet

3) Verified tablet is in development mode


I still get the error below:

blackberry-airpackager SudokuShared-1.2.0.bar -installApp -password password -launchApp -device
Error: Cannot connect: Connection to refused. Please check IP address settings for the target. You
 may have to reboot the target.




Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: Cannot deploy to device any more

Have you tried pinging it?

From the command line on your PC, do "ping".

If it reports a timeout, you likely have some network issues to resolve.

If it shows a response, the issue is with the PlayBook. Try restarting it, re-enable development mode, wait a minute or two (I believe it's still an issue that it will periodically not open up the port immediately), and try again.

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!