Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

Posts: 20
Registered: ‎07-25-2011
My Device: Playbook
My Carrier: rogers

Deployment Failed: Info: Sending request: Launch

I had all setup and working. But I had to uninstall Flash Builder and re-install again. Anyhow,

now I can't run the app using flash builder or debug.


I can't debug or run from inside the Flash builder. Debug tokens uploaded, certifgates are setup. 

But I can export the final build from Flash Builder and install it using the deploy files in the sdk folder using cmd. That works but when the app runs, its blank.


When I try to run or debug, this is what I get in Flash builder

Deployment Failed: Info: Sending request: Launch

Info: Action: Launch

Info: Debug air: on

Info: Updated debug host to

Info: Launching <app info>

result::FailedInfo: done



And on the device:

Unable to start application AppName-debug -Error code:8 



Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: Deployment Failed: Info: Sending request: Launch

Is the IP set correctly?
Posts: 172
Registered: ‎06-07-2010
My Device: BlackBerry 8520
My Carrier: Rogers

Re: Deployment Failed: Info: Sending request: Launch

Hello Jeevan,


Can you paste the contents of your blackberry-tablet.xml file? There could be non conformities there which could result in the FailedInfo: done failture.


Looking forward to your reply.

Raihan Masroor
BlackBerry Development Advisor
Posts: 20
Registered: ‎07-25-2011
My Device: Playbook
My Carrier: rogers

Re: Deployment Failed: Info: Sending request: Launch

Thanks but I found out the problem. My keys weren't updated in the xml file. Thanks for trying to help.

New Contributor
Posts: 6
Registered: ‎04-13-2011
My Device: Blackberry Playbook
My Carrier: blackberry playbook

Re: Deployment Failed: Info: Sending request: Launch

I am facing same proble . Please provide solution for this.

BlackBerry Development Advisor
Posts: 417
Registered: ‎10-27-2010
My Device: PlayBook

Re: Deployment Failed: Info: Sending request: Launch

I suggest to start a new thread an post exact output of the launcher, also would be nice to see command line (or steps) of how did you create your bar file

Posts: 52
Registered: ‎03-29-2012
My Device: Playbook, Dev Alpha
My Carrier: Telus

Re: Deployment Failed: Info: Sending request: Launch

Please explain what xml you're talking about and mark this as Solved. I have found at least 7 posts like this with no solution. Wasted 2 days of development so far.
New Member
Posts: 1
Registered: ‎01-10-2013
My Device: Simulator
My Carrier: none

Re: Deployment Failed: Info: Sending request: Launch

Please re-check the connection as the steps:

1. open simulator first

2. open QDE

3. open"window"-preference-blackberry-BlackBerry Deployment setup wizard

4. follow the steps and take care of the previous configuration if you had.

5. make sure your project-"run as "- run configuration has add the simulator as a target at the bottom of the first sheet

6. make sure your simulator can be available form QDE(ping ip is the best way)

7. when the simulator is stack, restart it and waiting for the ip available to retry.


Good Luck

Posts: 210
Registered: ‎05-18-2009
My Device: NA
My Carrier: NA

Re: Deployment Failed: Info: Sending request: Launch



The XML he mentions is the bar-descriptor.xml.  Specifically, name of author which must match the signing key.


The failure to launch simply means that the PlayBook received the file, but was not able to execute it. 


This means a signing issue (which can also be checked by hand using the BAR Verification bat file from RIM). 


Or it can mean that you lost some packets during transmission, and the BAR was corrupted and needs to be redeployed.


It can also mean a critical packaging error (zipping by hand perhaps?)


And sometimes it happens because one of your two XML files have bad values or non-standard XML tags.



Posts: 151
Registered: ‎09-28-2012
My Device: Blackberry Developer
My Carrier: Aircel

Re: Deployment Failed: Info: Sending request: Launch

i am also facing the same problem while running the app on simulator...


Deployment Failed: Info: Sending request: INSTALL_AND_LAUNCH
Info: Action: Install and Launch
Info: Debug native: on
Info: File size: 206827
Info: Installing com.example.CascadesProject.testDev_adesProjectf28abc9_...
Info: Processing 206827 bytes


please suggest me...

Feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.