Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
Posts: 382
Registered: ‎05-19-2008
My Device: BlackBerry Torch
My Carrier: AT&T

Re: Error - Packaging failed:255?

You are probably better off just making sure to run the blackberry-airpackager from within the BIN directory of the SDK.

 

Assuming your sdk is installed at: C:\SDK

then you would first type these commands:

C:                              (just in case you aren't already on CSmiley Happy

cd \sdk\bin

blackberry-airpackager blah blah blah

 

if your SDK is installed in a path with a space in the name, put quotes around the name. ie cd\"Playbook 0.9.4 sdk"\bin

Bill
-------------------------------------------
Check out my book on BlackBerry Development for Java.
And my other really really old book
My Apps: FlashKids
Contributor
Posts: 45
Registered: ‎03-19-2011
My Device: Playbook
My Carrier: N/A

Re: Error - Packaging failed:255?

I navigated to the sdks/ folder under the Flash Builder folder and ran the command line and I was able to run the command line but I get the Error:

Error: Access is denied

 

 

Here is the command line I entered:

blackberry-airpackager -package AIRHelloWorld.bar -installApp -launchApp <path/test-app.xml> <path/test.swf> -device <MyIPAddress> -password <MyPasswordHere>

 

thoughts?

Developer
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Error - Packaging failed:255?

try running your command prompt as Admin. even if you are an administrator, Right click on the command prompt applicatino and select "Run as Administrator". that should clear that error up. good luck!

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
Highlighted
Contributor
Posts: 45
Registered: ‎03-19-2011
My Device: Playbook
My Carrier: N/A

Re: Error - Packaging failed:255?

I got some more progress when running the command line with admin access. But I was still not able to get it to run entirely.

 

After I ran the command like, the program attempted to run in the siimulator. :-)

I saw the program's tile and it attempted to run, but it never loaded. The program remained white.

 

After I ran the command line, i noticed the following in the command prompt:

Invalid manifest file C:\Users\<USER>\AppData\Local\Temp\bar1145041985185739078.MF

 

What I think may be happening is that some required files are not being added to my command line. 

But I also have some other good news. I attempted to "run" the program through Flash Builder instead of "debugging" the program and it successfully loaded and ran the app. :-))))

 

I'm still unsyre exactly why I cannot debug the app, nor can I use a command line. However, at least now I can test the app.

 

Any ideas where i may be going wrong with either the debugging or the command line routes?

 

thanks!!!