Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Contributor
Posts: 26
Registered: ‎07-24-2009
My Device: Not Specified

FB not importing full SDK

I'm currently writing an app in Flash Builder 4.5 with PHP. When trying to import things like qnx.ui.buttons.Backbutton I get 

Multiple markers at this line:
-The import BackButton could not be found.
-The import ui could not be found.
-The import buttons could not be found.
-qnx

I can't quite work it out. Using BB Tablet OS SDK 2.0.0. for AIR. The qnx-air library isn't under the SDK folder in the package explorer, but rather under Referenced Libraries. "Add Platform specific libraries to library path" is checked, so I can't see the problem. In the Flex Build Path all the correct libraries seem to be there. I count 15 in total for the BB SDK. code snippet:

	import mx.events.FlexEvent;
			import qnx.ui.buttons.BackButton;
			import qnx.ui.skins.buttons.BackButtonSkinBlack;
			import qnx.ui.skins.buttons.BackButtonSkinWhite;
			
TIA
Contributor
Posts: 26
Registered: ‎07-24-2009
My Device: Not Specified

Re: FB not importing full SDK

Here's the error:

 

C:\Program Files\Research In Motion\blackberry-tablet-sdk-2.0.0\frameworks\libs\air\qnx-air.swc- DesignAssetLoader.CompleteTimeoutSWC file failed to load. Any component dependent on this SWC file will not be displayed in the Design Mode.The SWC may have failed to load because of:	*  Incompatible definitions caused by usage of a different SDK version	*  Missing referred class definitions 
Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: FB not importing full SDK

Hi,

 

Unfortunetly Flash Builder 4.5 with PHP is not supported by the BlackBerry AIR SDK. You need to be running Flash Builder 4.6. 

 

Regards,
Dustin

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
Contributor
Posts: 26
Registered: ‎07-24-2009
My Device: Not Specified

Re: FB not importing full SDK

Would using Flex 4.6 in Flash Builder 4.5 work?

Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: FB not importing full SDK

Sorry no, Flex is not the issue it's the IDE.

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
Contributor
Posts: 26
Registered: ‎07-24-2009
My Device: Not Specified

Re: FB not importing full SDK

Any other solutions so that I can use PHP?

Cheers
Highlighted
Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: FB not importing full SDK

We also support FDT5 for BlackBerry 10 development. I don't use it so I'm not really sure but it says it supports PHP. Worth checking out at least - http://fdt.powerflasher.com/.

 

Be warned it is on the pricy side but the team that builds the SDK here all use it. 

 

Dustin

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/