Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
New Contributor
Posts: 4
Registered: ‎02-16-2011
My Device: Play Book

HTML Component not displayed in Simulator

Hi,

 

I am trying to develop app for BB Playbook, when I run the code in Flash builder, it is appearing correctly. But when I try to deploy the package in Simulator, the HTML components (<mx:HTML>) created using are not appiearing, is this is the bug or I should use someother components to display the message?

 

Thanx

Mani

 

 

Developer
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: HTML Component not displayed in Simulator

The mx HTML component is not supported by the PB OS (sadly).  You have to use the less reliable, still under development QNX web view control.  There are lots of threads on it and how to use it.

New Contributor
Posts: 4
Registered: ‎02-16-2011
My Device: Play Book

Re: HTML Component not displayed in Simulator

Hi John,

 

Thanx for your quick response, what is the equivalent component in mxml can be used?

 

--Mani

Developer
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: HTML Component not displayed in Simulator

There is none.  You have to use the QNX AS web view class.  There is a thread covering how to encapsulate QNX classes in MXML containers that you might want to look at.

New Contributor
Posts: 4
Registered: ‎02-16-2011
My Device: Play Book

Re: HTML Component not displayed in Simulator

Hi John,

 

When I tried to add QNX Webviewer, the example below... I am still getting the compiler error

"1026: Constructor function must be instance methods". Am I missing anything, have tried to add the qnx-air.swc file too, I am using Flex Burrito...

 

http://supportforums.blackberry.com/t5/Tablet-OS-SDK-for-Adobe-AIR/Using-QNX-components-in-MXML/m-p/...

 

Thanx

Mani

New Contributor
Posts: 4
Registered: ‎02-16-2011
My Device: Play Book

Re: HTML Component not displayed in Simulator

Sorry  missed to mention SDK 0.9.1

Highlighted
Developer
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: HTML Component not displayed in Simulator

0.9.3 is more stable.