Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Developer
Posts: 238
Registered: ‎03-14-2012
My Device: PlayBook 2.0
My Carrier: AT&T

How to use the BB10 invocation framework with the QNXDevice.ane in Flash CS 5.5?

Hi,

 

I would like to use the BB10 invocation framework.

I made everything like described in this tutorial but the invoke event returns NULL for everything in it.   

 

I'm using Flash CS 5.5 with the Air 3.1 SDK. 

 

Since .ANE's are not supported in CS 5.5, I renamed it to .SWC

Could that cause the NULL error?

If so, how to use an ANE with Flash CS 5.5?

 

 

Thanks for any feedback and ideas!

Vibes

 

P.S. Anybody managed to get the invocation framework to work with Flash CS 5.5 yet? 

Developer
Posts: 1,280
Registered: ‎03-03-2011
My Device: Playbook, Z10, Q10, Z30 with Files & Folders and Orbit of course
My Carrier: Vodafone

Re: How to use the BB10 invocation framework with the QNXDevice.ane in Flash CS 5.5?


Since .ANE's are not supported in CS 5.5, I renamed it to .SWC

Could that cause the NULL error?


That is certainly the cause. ANE is an SWC with native code added. If the native code is missing, that will certainly cause errors or unexpected behaviour.

 

I don't use Flash CS 5.5 to build apps, so I can't help you, but this tutorial might be of interest:

http://www.youtube.com/watch?v=Axg6E001a7I

 

Files & Folders, the unified file & cloud manager for PlayBook and BB10 with SkyDrive, SugarSync, Box, Dropbox, Google Drive, Google Docs. Free 3-day trial! - Jon Webb - Innovatology - Utrecht, Netherlands
Developer
Posts: 238
Registered: ‎03-14-2012
My Device: PlayBook 2.0
My Carrier: AT&T

Re: How to use the BB10 invocation framework with the QNXDevice.ane in Flash CS 5.5?

The guy in the video is renaming the ANE to SWC.

 

How can I add the Air 3.1 SDK to Flash CS 6?

I tried it and and error pops up saying it needs to  be at least AIR 3.2.