Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Contributor
Posts: 27
Registered: ‎02-17-2013
My Device: Developer-BB10
My Carrier: ---
Accepted Solution

Icon not getting displayed

I'm developing an app for BB10. I've included an 80x80 png to the src folder and I've mentioned the name of the image correctly in the bar-descriptor.xml file using the code

  <icon>

      <image>Balloon.png</image>

  </icon>

 

But the icon is not getting displayed in the simulator.Have I missed something? Please help.

 

Developer
Posts: 1,251
Registered: ‎12-29-2010
My Device: PlayBook, Z10 LE, Dev Alpha C

Re: Icon not getting displayed

There are several threads on this issue, like this one for example.

Contributor
Posts: 27
Registered: ‎02-17-2013
My Device: Developer-BB10
My Carrier: ---

Re: Icon not getting displayed

Thank you very much. I did the same overwriting and the icon got displayed finally in the simulator. But will it get displayed likewise in the actual device too?

Developer
Posts: 1,251
Registered: ‎12-29-2010
My Device: PlayBook, Z10 LE, Dev Alpha C

Re: Icon not getting displayed

It should.  The only time I've seen an app icon fail to get updated once the app got packaged correctly and re-loaded on to a device was on a webOS phone - the webOS UI manager caches the icons, so sometimes icon updates were not taking (maybe only in the case that the desired icon had the same name as the undesired icon).  In that case a device restart was required to get the UI manager process to re-read the correct icon from the installed app directory on the device.  However, I don't know for sure that BB10 doesn't behave the same way.  In any case, if BB10 caches icons the same way, a device restart probably fixes the problem.  Bottom line though, it should work on the device the same way as on the simulator.

Contributor
Posts: 27
Registered: ‎02-17-2013
My Device: Developer-BB10
My Carrier: ---

Re: Icon not getting displayed

Thank you. Smiley Happy