Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Regular Contributor
Posts: 93
Registered: ‎02-03-2011
My Device: Not Specified
Accepted Solution

QNXStageWebView all of a sudden not working

My app has been live for quite some time on the Tablet.  All of a sudden I am receiving emails and bad user reviews saying that it is not working.  It makes use of QNXStageWebView and the problem seems to have been narrowed there.  Has there been some system changes in the last several weeks that would have caused this?  Thanks for any info anyone can provide.

Developer
Posts: 1,280
Registered: ‎03-03-2011
My Device: Playbook, Z10, Q10, Z30 with Files & Folders and Orbit of course
My Carrier: Vodafone

Re: QNXStageWebView all of a sudden not working

IIRC, the last update of the OS (2.1.0.1526) was back in February. Is your user running that version?

 

According to the sparse change log, it contained "browser improvements", but of course no mention of what had changed.

 

Are you loading local files into the webview, or accessing a remote site.

 

If remote, could that site have changed? Have you checked wifi connectivity, BES policies (if applicable)?

Files & Folders, the unified file & cloud manager for PlayBook and BB10 with SkyDrive, SugarSync, Box, Dropbox, Google Drive, Google Docs. Free 3-day trial! - Jon Webb - Innovatology - Utrecht, Netherlands
Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: QNXStageWebView all of a sudden not working

Does the page your loading in the webview load alright in the browser?

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
Regular Contributor
Posts: 93
Registered: ‎02-03-2011
My Device: Not Specified

Re: QNXStageWebView all of a sudden not working

Yes the website opens in the browser directly (and appears to be operating properly).  And it opens in the QNXStageWebView as well within my app.  What seems to no longer work is the 'back and forth' between the website and the AIR app using:

JavaScriptCallbackEvent.JAVA_SCRIPT_CALLBACK

 

It started happening more recently than the OS upgrade (first complaints were about a month ago).

 

...Jim

 

Highlighted
Regular Contributor
Posts: 93
Registered: ‎02-03-2011
My Device: Not Specified

Re: QNXStageWebView all of a sudden not working

Problem solved guys.  Nothing to do with BB PB.  Turns out YouTube deprecated an api that I had been using.