Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

New Contributor
Posts: 2
Registered: ‎09-03-2011
My Device: Blackberry Playbook
My Carrier: N/A

Release build shows WSOD

I have flex builder 4.5 (windows) and I'm able to debug and deploy my application on the playbook and everything works fine.  I have another machine which is a linux box which I build my application for release and everything gets signed and has the appropriate files in the META-INF folder (AUTHOR.EC, AUTHOR.SF, MANIFEST.MF, RDK.EC, and RDK.SF). When I try to run it on the device or the simulator all I get is a white screen.  Is there anyway that I can determine what is going on or has anybody ran into this before?

Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: Release build shows WSOD

Since you've seen those individual files in META-INF, it seems you know how to extract/examine the contents of a .bar file.

I'd suggest simply comparing the contents of the two .bar files involved, one from Flex on Windows and the other from the Linux machine. There must be some difference that could be seen by comparing file sizes, md5 checksums of files, or using a diff tool to compare text files.

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
New Contributor
Posts: 2
Registered: ‎09-03-2011
My Device: Blackberry Playbook
My Carrier: N/A

Re: Release build shows WSOD

Thanks for the quick reply.  From a quick search on my computer I don't see where Flex Builder saves the bar files.  In flex builder it is using the debug token and the linux box is doing the signing of the bar file.  I just tried from the command line and it is giving the same result.  I wonder if it has anything to do with the compiler options that I'm using in my ant script, I know that this script worked in the pre-release build 0.9.x but something might have changed in the latest version:

<mxmlc file="${build}/${ant.project.name}.mxml"        

               locale="${locale}" static-rsls="true"       

               accessible="true" configname="air"       

              debug="${compile.debug}" failonerror="true"       

              fork="true" maxmemory="512m"       


    <load-config filename="${FLEX_HOME}/frameworks/airmobile-config.xml" />   

    <source-path path-element="${src}"/>   

    <library-path dir="${playbook.home}/frameworks/libs/blackberry" includes="*.swc" append="true"/>   

    <library-path dir="${playbook.home}/frameworks/libs/qnx-screen" includes="*.swc" append="true"/>   

    <library-path dir="${playbook.home}/frameworks/libs/air" includes="qnx-air.swc" append="true"/>