Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Contributor
Posts: 11
Registered: ‎01-10-2011
My Device: Playbook
My Carrier: None

Re: Signing App: Manifest Error: invalid value '1.0.0.0' for application-requires-system

I went through a phase of trying everything for the version I think it must be of the form X.X.X and nothing else

AiFlex Limited Get your app developed with us
Regular Contributor
Posts: 58
Registered: ‎12-26-2010
My Device: Torch 9800
My Carrier: Rogers

Re: Signing App: Manifest Error: invalid value '1.0.0.0' for application-requires-system

I have no clue whats going on guys. I am now getting this message. 

 

"barsigner error: Certificate chain not found for: RDK. RDK must reference a valid KeyStore key entry containing a private key and corresponding public key certificate chain."

 

I have applied for a new .csj file, and this time I am going to try to compile on my mac. I am  not too familiar with using terminal, I love my cmd so wish me luck!

Regular Contributor
Posts: 58
Registered: ‎12-26-2010
My Device: Torch 9800
My Carrier: Rogers

Re: Signing App: Manifest Error: invalid value '1.0.0.0' for application-requires-system

Problem solved! I upgraded to SDK v 0.9.4 and got a new set of keys and worked flawlessly! definitely make sure you set the version number to something other than 1.0.0 something like 1.0.x or 1.x.x for anyone else with the problem. Runs great in sim version 0.9.4 as well signed and good to go!

Highlighted
Developer
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Signing App: Manifest Error: invalid value '1.0.0.0' for application-requires-system

@tayshun: Glad you got it worked out! thanks for the update and good luck on the ur submission!

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman