Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Highlighted
New Contributor
Posts: 6
Registered: ‎02-13-2011
My Device: Not Specified
Accepted Solution

Simulator can't connect to local network services

Hello all.

 

I am sure that this has been answered somewhere, but I can't find it.

 

I have the Playbook sim 0.9.3 installed and (mostly) working. It accesses the internet fine, apps load and run fine.

 

However, what I can't seem to do is access any local network services. I have tried even by IP address, and just get errors.

 

I do not have a DNS server on my local network right now, but could set one up, if this would help.

 

Any suggestions?

Developer
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Simulator can't connect to local network services

hey,

 

try changing the adapter settings in your VMware player to "bridged" and restart it. this will give your simulator an actual IP from the router connecting all your computers in the network and it and the simulator will be treated just like any other computer. hope that helps. good luck!

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
New Contributor
Posts: 6
Registered: ‎02-13-2011
My Device: Not Specified

Re: Simulator can't connect to local network services

Thank you for the fix.

 

 

I tried it before, but it seemed that I had to power of and restart the simulator 2 or three times before it worked. it kept saying that there were no interfaces available.

 

 

New Contributor
Posts: 2
Registered: ‎07-05-2011
My Device: Rim PlayBook
My Carrier: At&T

Re: Simulator can't connect to local network services

Just to clarify, don't check the box that says "Replicate physical network connection state" after selecting "Bridged".  When I had this checked, I was not able to get an IP Address.

New Member
Posts: 1
Registered: ‎02-19-2012
My Device: Playbook
My Carrier: 5124231959

Re: Simulator can't connect to local network services

I just installed and have the same problem using Mac Fusion. Tried Bridged and NAT from the VM, restarted several times. What am I missing?