Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Posts: 11
Registered: ‎10-30-2010
My Device: Not Specified

Switching Java versions on Mac

As per the SDK install instructions I followed the instructions for switching Java version to 6 by changing the sym link. Since I have been using Java 5 for some other (i.e. non-PlayBook) projects I tried to switch back and found that reversing the instructions didn't work. Basically I ended up with a totally broken Java install on my Mac (Im running Mac OS 10.5.8) - major problem since I had other projects I need to work on!


Anyway after poking around for awhile I ended up downloading and installing the latest Java update from Apple's support site and managed to get Java working again (phew!).


So my question, is there some special reason you guys dont use the Java Preferences applet in /Applications/Utilities to modify Java versions instead of ( the more error-prone) method of messing with sym links? If there's no special reason, then maybe you can update the SDK install docs for developers on Mac to use the applet to switch versions since it was designed specifically for that purpose.


Posts: 20
Registered: ‎10-09-2010
My Device: Bold 9700
My Carrier: Base (Belgium)

Re: Switching Java versions on Mac



I guess I'm having the same problem (MacBook, OS X 10.5.8). This is the (probably useless) error report:



Process:         BlackBerryTabletSDK-Air-Installer- [987]
Path:            /Users/sbeeckma/Downloads/BlackBerryTabletSDK-Air-Installer-
Identifier:      BlackBerryTabletSDK-Air-Installer-
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  launchd [143]
Interval Since Last Report:          1061 sec
Crashes Since Last Report:           1
Per-App Interval Since Last Report:  0 sec
Per-App Crashes Since Last Report:   1
Date/Time:       2010-12-06 22:56:56.586 +0100
OS Version:      Mac OS X 10.5.8 (9L31a)
Report Version:  6
Anonymous UUID:  20A81E81-5A11-4ED2-9A8C-4251F370F7BC
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000008
Crashed Thread:  0
Thread 0 Crashed:
0   com.apple.JavaVM               0x000000010001b0e9 AcceptJVMInfo + 27
1   com.apple.JavaVM               0x000000010001628b AddJVMsFromSampledFile + 148
2   com.apple.JavaVM               0x00000001000196bf CreateInstalledFrameworkJVMInformation + 272
3   com.apple.JavaVM               0x00000001000166db CreateListOfAllInstalledJVMs + 28
4   com.apple.JavaVM               0x0000000100018e04 CreateCompleteJVMListSortedByUserPrefsForTask + 100
5   com.apple.JavaVM               0x0000000100018f72 JVMCreateJVMListForTaskVersionAndArchs + 40
6   ...ple.JavaApplicationLauncher 0x0000000100004aba ChooseJVMForVersionAndProperties + 146
7   ...ple.JavaApplicationLauncher 0x0000000100006539 launchJavaApplicationWithJVMInfo + 253
8   ...nstaller- 0x0000000100000b78 0x100000000 + 2936
Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000100112e90  rbx: 0x0000000100112630  rcx: 0x00007fff7023e580  rdx: 0x0000000100112e90
  rdi: 0x0000000000000000  rsi: 0x0000000000000000  rbp: 0x00007fff5fbfdd60  rsp: 0x00007fff5fbfdd20
   r8: 0x0000000000000000   r9: 0x0000000000000000  r10: 0x0000000100024cb0  r11: 0x00007fff80446f90
  r12: 0x0000000000000000  r13: 0x0000000100108000  r14: 0x0000000100112900  r15: 0x0000000100112900
  rip: 0x000000010001b0e9  rfl: 0x0000000000010202  cr2: 0x0000000000000008


Gonna try a reboot and then reinstalling the latest java update.

Posts: 20
Registered: ‎10-09-2010
My Device: Bold 9700
My Carrier: Base (Belgium)

Re: Switching Java versions on Mac

For the record:


I did a "sudo mv JavaVM.framework/ backupJavaVM.framework backupJavaVM.framework" in /System/Library/Frameworks/ before running the Mac OS X 10.5 Java Update 8. After that, "java -version" returns version 1.5.0_26.


This somehow solves the problem of the Tablet Air SDK Installer not wanting to run.


However, after following the Flash Builder 4.5 Hello World instructions, I get this:Afbeelding 8.png


My guess: I installed Flash Builder 4.5 before I tried to fix the JRE version problem, and by doing so, I messed up the ClassLoader version.

New Member
Posts: 1
Registered: ‎12-26-2010
My Device: Not Specified

Re: Switching Java versions on Mac

I'm also encountering the same problems... updating to the latest (update8) version didn't work out...


my Java, Flash Builder & Flash professional won't start anymore...


Posts: 21
Registered: ‎03-15-2011
My Device: Playbook
My Carrier: None

Re: Switching Java versions on Mac

Similar problem. MacBook Pro OS 10.5.8. Upgraded Java to 1.6. Now Flash Builder 4 and Burrito will not launch (different errors when launching either of them).

Flash Builder 4.5 launch error:
The JVM shared library "/System/Library/Frameworks/JavaVM.framework"
does not contain the JNI_CreateJavaVM symbol.

Flash Builder 4 launch error will not copy/paste and is too long to transcribe.

System information:
Java info
java version "1.6.0_24"
Java(TM) SE Runtime Environment (build 1.6.0_24-b07-334-9M3326)
Java HotSpot(TM) 64-Bit Server VM (build 19.1-b02-334, mixed mode)

MacBook Pro info
Model Name: MacBook Pro
  Model Identifier: MacBookPro3,1
  Processor Name: Intel Core 2 Duo
  Processor Speed: 2.2 GHz
  Number Of Processors: 1
  Total Number Of Cores: 2
  L2 Cache: 4 MB
  Memory: 4 GB
  Bus Speed: 800 MHz
  Boot ROM Version: MBP31.0070.B07
  SMC Version (system): 1.16f10
  System Version: Mac OS X 10.5.8 (9L31a)
  Kernel Version: Darwin 9.8.

Bugs submitted to Adobe and RIM:

PlayBook App: Flash Performance Tester