Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: White Black Screen When loading app on Playbook.

Yes - Unfortunately anything above AIR 3.1 is not supported at this time. Are you using any AIR specific APIs? If not you should be able to get it to work just by publishing a swf with Flash player 11.1 selected.

 

You can test your app by running on a simulator to make sure your application works before submitting - http://us.blackberry.com/sites/developers/resources/simulators.html

 

Regards,
Dustin 

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
Trusted Contributor
Posts: 100
Registered: ‎03-01-2012
My Device: Bold 9700
My Carrier: Rogers

Re: White Black Screen When loading app on Playbook.

[ Edited ]

OKay, I'll try that, BTW does it matter that my grapichal Aid is using AIR 3.3? And the latest Flash PLayer that Adobe Flash CS5.5 supports is 10.2, is it ok if I use 10.2, becuase I dont want to update that? BTW I followed you on Twitter Smiley Happy

Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: White Black Screen When loading app on Playbook.

No it shouldn't matter that you have AIR 3.3 running the graphical aid. Yes 10.2 should be fine for what you're trying to accomplish.

 

Cheers,
Dustin 

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
Trusted Contributor
Posts: 100
Registered: ‎03-01-2012
My Device: Bold 9700
My Carrier: Rogers

Re: White Black Screen When loading app on Playbook.

Bad news everyone, My app got denied AGAIN, i'm realy tired of this, I should be putting my time into developing apps, not trying to submit them. I'm considering moving to Android because I don't know what to do. I like the Blackberry Platform, but I cant get my app to work on it. If any of you guys have any suggestions on what I can do, I would really appriciate it, and dmalik, do you hvae a Playbook? becuase the Simulator does not work on my computer So can you test my app on your Playbook? Thanks for you Help everyone.

Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: White Black Screen When loading app on Playbook.

What operating system are you trying to install the simulator in? Did you follow my guide to create your .bar file?

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
Trusted Contributor
Posts: 100
Registered: ‎03-01-2012
My Device: Bold 9700
My Carrier: Rogers

Re: White Black Screen When loading app on Playbook.

Yes, I did use you guide. And i'm trying to make the simulator in Ubuntu, but the problem is installing Java, I tried so many guides for installing the jre but they didn't work. So if I send you the .bar will you test my app on you Playbook? Thanks
Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: White Black Screen When loading app on Playbook.

Hi,

 

It would be much more effecient if we can get you up and running testing your own applications. You can use the simulators in Linux Here is a guide on how to install VMware Player in Ubuntu - http://www.howtoforge.com/how-to-install-vmware-player-on-ubuntu-11.04-linux-mint-11 

 

Here is where you can download the PlayBook simulator for Linux - http://us.blackberry.com/sites/developers/resources/simulators.html

 

Regards,

Dustin

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
Trusted Contributor
Posts: 100
Registered: ‎03-01-2012
My Device: Bold 9700
My Carrier: Rogers

Re: White Black Screen When loading app on Playbook.

Okay, so I got the simulator working but when I try to deploy my app to the sumulator I get: "Error: Cannot connect: Connect to /<Ipaddress> timed out. Please check IP address settings for the target. You may have to reboot the target."

I tried restarting the sim and I also tried turing Dev mode off and back on but nothing worked. You guys have any suggestion on what to do. Thanks.

Developer
Posts: 1,251
Registered: ‎12-29-2010
My Device: PlayBook, Z10 LE, Dev Alpha C

Re: White Black Screen When loading app on Playbook.


AGZ123 wrote:

You guys have any suggestion on what to do. Thanks.



If you're not already using search on the forums, you'll probably make faster progress if you do.  A quick search for "cannot connect to simulator" yielded about 90 threads.