Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Posts: 32
Registered: ‎02-22-2011
My Device: Not Specified
Accepted Solution

compile .as file with amxmlc problem

To make a long story short, I am using windows 7 32 bit.  I had a command line window open and was using it to compile my classes and package to the VM (I had to because i was getting a command line to long from burrito, but that's a different story).


However, I closed this window and had to open a new one.  Once i did this, though, the amxmlc command stopped working (literally the exact same thing i had typed into the previous window seconds beforehand.


that command was "amxmlc Patience.as".  I am in the right directory and the amxmlc.bat is in a directory in my poath variable, too.


Help! (Thanks)

Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: compile .as file with amxmlc problem

not sure if this'll work, but try opening another command prompt this time right clicking on it first and click on "Run as Adminstrator" and try running the command. good luck!

J. Rab (Blog) (Twitter)
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: compile .as file with amxmlc problem

First confirm in the new window that the PATH is what you think it is.  Type "set path" or just "set" to see it.


Next, confirm that both the amxmlc.bat file is still in that folder, and that the program it calls is also there. That would be mxmlc.exe.


If that's all good, cut and paste the command and error message here so we don't have to guess... (masking out any private information that may reveal).

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Posts: 32
Registered: ‎02-22-2011
My Device: Not Specified

Re: compile .as file with amxmlc problem

That worked.  Thanks!  I don't remember having to run it as an admin before, but i guess that's that.