Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
New Contributor
Posts: 3
Registered: ‎09-18-2011
My Device: Playbook
My Carrier: none

create debug token issue

I started with this document

 

http://docs.blackberry.com/en/developers/deliverables/27280/Running_unsigned_apps_debug_tokens_15850...

 

tthat explained how to get debug tokens. So I requested my signing keys and recieved client-PBDT-xxxxxxxxx.csj, I then followed:

 

 http://docs.blackberry.com/en/developers/deliverables/27280/Configure_app_signing_from_cmd_line_1463...

 

to create a .p12 file. Then I tried running: blackberry-debugtokenrequest -register -cskpass <your csk password> -csjpin <your CSJ PIN> <path to your CSJ registration file> and get the following error: barsigner error: already registered with PBDT. I simple followed the steps, any ideas what I am doing wrong?

 

Regards,

Justin

 

Retired
Posts: 172
Registered: ‎06-07-2010
My Device: BlackBerry 8520
My Carrier: Rogers

Re: create debug token issue

Hello jhollick,

 

From the error message "already registered with PBDT" it looks like your keys have already been registered and hence you do not need to register them again. You can only register your PBDT keys once. If you wish to register them again, you will need to request for another set of keys.

 

To confirm that your keys have been registered, can you please navigate to "%HOMEPATH%\AppData\Local\Research In Motion" and check to see if you have the files:

barsigner.csk

barsigner.db

 

If these files are present, can you open barsigner.db with a text editor and check if you have the following entry:

PBDT=<clientID>http\://www.rim.net/Websigner/servlet/PBDT-Waterloo

 

If you do have these entries, your PBDT keys have been registered and you can continue with the process for uploading your debug token onto your playbook.

 

Looking forwarding to your reply.

Raihan Masroor
BlackBerry Development Advisor
Highlighted
New Member
Posts: 1
Registered: ‎10-26-2013
My Device: z10
My Carrier: etisalat

Re: create debug token issue

i am having the same error 

its already registered 

 

and i moved to the sec move which i bla bla bla 

until i open the b-createdebugtoken file and it says :

there was an error generating the debug token echo is off 

and i cant do anything 

could you plz help