Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Regular Contributor
Posts: 93
Registered: ‎02-03-2011
My Device: Not Specified
Accepted Solution

debug token problem

Hi folks - Any help / advice on the following would be much appreciated:


About a month ago I successfully created a debug token and uploaded it to my PlayBook.  I believe it has now expired (on the PlayBook it says: "Valid: no"). I am using the command line.


I now want to create and upload another debug token.  I followed the instructions on the same website.


1. registered the .csj file using the blackberry-debugtokenrequest

[I did this by mistake not knowing that it didn't have to be done again.  It gave me an error message: "Already registered with PBDT."  I am just letting you know that I did this in case it is a contributor to my problem below.


2. requested a debug token using the blackberry-debugtokenrequest command.  I have now received an error message:


debugtokenrequest error: keystore load: failed to decrypt safe contents entry: javax.crypto.BadPaddingException: Given final block not properly padded.


I have googled and searched the forums for this message but no luck as to determine the cause. 


Has anyone else seen this?  Any ideas?  Thanks.




BlackBerry Development Advisor
Posts: 15,852
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: debug token problem

What version of the BlackBerry Tablet OS SDK are you using?  Are you using a non beta release (1.x.x)?  If you are using a beta release please upgrade to the latest version.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Posts: 231
Registered: ‎05-03-2011
My Device: PlayBook V1 and proud of it :-)
My Carrier: Legs

Re: debug token problem

Have you deleted the old degub token?

Keep the Forum productive and useful for all. Click Kudos button if I've helped you. Select Solved to help everyone.

PlayBook qualifying app - Pandoras' Lights
Blog - CoCopia.co.uk Catch me on Twitter cocopia_apps
Regular Contributor
Posts: 93
Registered: ‎02-03-2011
My Device: Not Specified

Re: debug token problem

Thank you so much for helping me solve this - the version of the bin folder was the issue.