Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Adobe AIR Development

Reply
Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: failure 821 Application-Requires_system: unrecognized system name BlackBerry 10

Yes unfortunetly right now you must update your SDK path in preferences of Flash Builder. (Added sample screenshot if anyone else stumbles on this thread)

 

sdkPath.png

 

The BlackBerry 10 SDK will be suppported on PlayBook AFTER PlayBook gets updated to BlackBerry 10. The PlayBook SDK will eventually go away and not be used.

 

I agree there is confusion right now having 2 SDKs to install and use but this is temporary. The challenge is that BlackBerry 10 and PlayBook are different operating systems, behave very differently, and have unique UI's.

 

In the short term I will bring this up with the documentation team to see if there is something we can do to help alleviate this confusion. 

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
Developer
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: failure 821 Application-Requires_system: unrecognized system name BlackBerry 10

It is best to have one workspace for PlayBook apps and another workspace bor BB10 apps. Each workspace can reference a different BB SDK path.
New Contributor
Posts: 3
Registered: ‎01-24-2013
My Device: BlackBerry Curve 9320
My Carrier: 02

Re: failure 821 Application-Requires_system: unrecognized system name BlackBerry 10

Hi

 

I have download the latest tools etc.

  BlackBerryTabletSDK-Air-Installer-2.1.0-Win-201210011021

  BlackBerryPlayBookSimulator-Installer-2.1.0-1032-Win-201209272349.exe

 

Both are installed, but I'm unable to install an Air application.

 

Keep getting this error:-

result::failure 821 Application-Requires-System: unrecognized system name 'Black

Berry 10'

 

 

 

C:\dev\blackberry\TestApp>blackberry-airpackager -package stickman.bar -installA

pp -launchApp stickman-app.xml stickman.swf -device 192.168.232.128 -forceAirVer

sion 3.1

C:\Program Files (x86)\Research In Motion\blackberry-tablet-sdk-3.0.0\lib\adt.ja

r

Warning: Using default icon: C:\Program Files (x86)\Research In Motion\blackberr

y-tablet-sdk-3.0.0\samples\icons\blackberry-tablet-default-icon.png

Info: Package created: stickman.bar

Info: Sending request: Install

Info: Action: Install

Info: File size: 16581

Info: Installing ...

Info: Processing 16581 bytes

actual_dname::

actual_id::

actual_version::

result::failure 821 Application-Requires-System: unrecognized system name 'Black

Berry 10'

 

Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: failure 821 Application-Requires_system: unrecognized system name BlackBerry 10

It appears that you also have the BB10 3.0 Beta SDK installed as well and it is using that vs the PlayBook 2.1 SDK. I noticed this in this line in your log:

 

C:\Program Files (x86)\Research In Motion\blackberry-tablet-sdk-3.0.0\samples\icons\blackberry-tablet-default-icon.png

 

The default location for the 2.1 SDK is: C:\Program Files\Research In Motion\blackberry-tablet-sdk-2.1.0

 

Regards,

Dustin

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
New Contributor
Posts: 3
Registered: ‎01-24-2013
My Device: BlackBerry Curve 9320
My Carrier: 02

Re: failure 821 Application-Requires_system: unrecognized system name BlackBerry 10

Hi

 

The problem seems to be that the "blackberry-airpackager", for blackberry-tablet-sdk-3.0.0 is putting the

wrong Application-Requires-System, version into the bar MANIFEST.MF

 

Application-Name: stickman

Application-Id: testRel_test2f235b17

Application-Description: stickman

Application-Version: 1.0.0.1

Application-Version-Id: testMS4wLjAuMSAgICAgICAgICA

Application-Requires-System: BlackBerry 10/1.0.8.0

Application-Development-Mode: false

 

 

If I know the Application-Requires-System version for the Playbook I could must replace this value

with the correct one.

New Contributor
Posts: 3
Registered: ‎01-24-2013
My Device: BlackBerry Curve 9320
My Carrier: 02

Re: failure 821 Application-Requires_system: unrecognized system name BlackBerry 10

Hi

 

Yea I had set the path to "C:\Program Files (x86)\Research In Motion\blackberry-tablet-sdk-3.0.0\bin"

 

Change it to: C:\Program Files\Research In Motion\blackberry-tablet-sdk-2.1.0\bin, has fixed the problem.

 

Thanks

Retired
Posts: 427
Registered: ‎02-22-2012
My Device: BlackBerry Z10, BlackBerry Dev Alpha C, BlackBerry PlayBook
My Carrier: Bell

Re: failure 821 Application-Requires_system: unrecognized system name BlackBerry 10

[ Edited ]

The SDK's are specific to their OS. PlayBook OS and BlackBerry 10 are different OS's. If you are creating a PlayBook application you need to use the 2.1 SDK. 

 

In your command specify the exact bat your targeting:

 

"C:\Program Files\Research In Motion\blackberry-tablet-sdk-2.1.0\bin\blackberry-airpackager" -package etc.

 

EDIT: Noticed you beat me to it. Happy to hear you got it working.

Follow me on Twitter: @dustinmalik
-----------------------------------------------------------------------------------------------------
Keep up to date on BlackBerry development: http://devblog.blackberry.com/
Contributor
Posts: 10
Registered: ‎12-15-2010
My Device: Playbook Simulator - Platform 1.0.0.0

Re: failure 821 Application-Requires_system: unrecognized system name BlackBerry 10

Hello,

 

I need a help. We made a our playbook app update and realased them. However users were not able to install because of this same error we had.

 

My SDK version is 3.2. Do I need to use different SDK? If so, please let me know where I can find those SDK.

 

Thanks in advance.

 

yamasnax

IdeaShaker