Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development

Reply
Highlighted
New Contributor
Posts: 2
Registered: ‎10-25-2013
My Device: 2.1.0 BlackBerry Playbook
My Carrier: Airtel
Accepted Solution

Android-BB in app purchase, Which Google IAP version should I use to get proper response ?

Hello

I've repackaged our Android App to use it on the Playbook and all works. The only problem is with in app purchase, it didn't respond.

For In app purchase I have taken care about SKU and transaction signature verification.

 

For testing I have followed this instruction
http://supportforums.blackberry.com/t5/Android-Runtime-Development/Playbook-Beta-2-1-In-App-Payments...

 

I can download the app but its didn't respond. In- app purchase doesn't work.

 

In same post few people said Google IAP V3.0 doesn't work. We are using Google IAP V3.0 actually Google has released IAP V5.0 we are in process to integrate that.

 

I want to know which Google IAP versions works perfectly fine in BB, as I can see V3 and V5 are not working. So Do I need to try with V2, actually Google has deprecated V2 code, so Just wanted confirmation from any BB developer about IAP version, Which version should I use ?

Thanks!
Makrand

Retired
Posts: 159
Registered: ‎11-21-2008
My Device: BlackBerry 10
My Carrier: Rogers

Re: Android-BB in app purchase, Which Google IAP version should I use to get proper response ?

Hello Makrand,

 

You'll have to use v2. Version 3 uses the Google Play SDK which is not supported.

 

For any additional questions on In app payments, check out our documentation at: https://developer.blackberry.com/android/apisupport/apisupport_inapp_payments_support.html

 

Cheers,

Matt

Matt Whiteman
Product Manager, Android, BlackBerry Java & Simulators