Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development

Reply
New Contributor
Posts: 2
Registered: ‎10-19-2011
My Device: PlayBook
My Carrier: None

Android app launching problem - Unable to connect - from eclipse

Background: I upgraded my playbook to 2.0, downloaded the eclipse plug-in, turned on debug mode, set up a debug token, right clicked my project and clicked "Add Blackberry Nature" in eclipse, and finally right clicked and clicked Run as "Blackberry Application" in eclipse.  (that was to get you up to speed on how I got to the problem)

 

The Problem: The problem is after it compiles for a minute, Eclipse pops up a window that says

 

"'Launching <app name>' has encountered a problem - Connecting 169.254.0.1 to ADB failed!"

 

and in the Console output I see

 

[<date> - BlackBerry] unable to connect to 164.254.0.1:5555.  

 

I also tried connecting from the command line adb with the same result.  I have restarted the playbook, eclipse, and the computer multiple times with no changes.  I am at a loss for how to proceed with testing my android app on the playbook.  Any help or advice is greatly appreciated.

Developer
Posts: 185
Registered: ‎04-05-2011
My Device: PlayBook
My Carrier: Bouygues Telecom

Re: Android app launching problem - Unable to connect - from eclipse

I packaged my android app to a signed bar using the online tool, and deployed it to the playbook using the blackberry-deploy command line tool, worked all right... not tested debugging from eclipse yet though
Julien
Web: smugrik.org Follow: @Smugrik
PlayBook apps:
OSCream
kiPass
New Contributor
Posts: 2
Registered: ‎10-19-2011
My Device: PlayBook
My Carrier: None

Re: Android app launching problem - Unable to connect - from eclipse

Thanks for the suggestion. I was really hoping to be able to test it without signing, but I guess I might have to fall back to using the online tool.

 

I hope to eventually find a solution with the plugin though because if something doesn't work right, fixing and then using the online tool in an endless loop seems like it would get old fast.

Visitor
Posts: 1
Registered: ‎12-07-2011
My Device: BlackBerry Playbook
My Carrier: 0

Re: Android app launching problem - Unable to connect - from eclipse

Hi,

 

Im new here. Im having trouble connecting adb to my playbook. Ive tried to ping the device in terminal and has reply,but when i try to connect with adb it says unable to connect. and i tried to view the device using adb device but nothing recognize.

 

Please help. and im using mac is there any issue regarding to it? 

 

Thank you all Smiley Very Happy

Regular Contributor
Posts: 63
Registered: ‎12-24-2010
My Device: Torch

Re: Android app launching problem - Unable to connect - from eclipse

Same issue here. 'Instaling' signed apps on the Playbook works every time, but 'Running' or 'Debugging' an unsigned app always errors out with 'unable to connect to ADB'....

Highlighted
Developer
Posts: 42
Registered: ‎01-07-2011
My Device: BB Q10, Z10, Playbook
My Carrier: Telus

Re: Android app launching problem - Unable to connect - from eclipse

Take a look at the following thread. It describes how to solve this problem.

http://supportforums.blackberry.com/t5/BlackBerry-Plug-in-for-Android/Failed-Launching-app-from-ecli...

---------------------------------------
Please click the "kudos" in my post if I was able to help you on this issue.
Please mark thread as resolved if I was able to fix the issue!!
Twitter: @wiisniper
My Free Playbook Apps (no ads):
Speech timer Plus http://appworld.blackberry.com/webstore/content/83847/
Speech timer http://appworld.blackberry.com/webstore/content/34640/