Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Highlighted
New Contributor
Posts: 9
Registered: ‎03-03-2013
My Device: BlackBerry Playbook
My Carrier: Vodafone
Accepted Solution

BlackBerry Tablet OS Graphical Aid can't sign application

[ Edited ]

I use BlackBerry Tablet OS Graphical Aid to convert apk to bar. It convert the application but can't sign the application.

Here is my operation output

Batch Bar Signer process started.....

-------------------Fling.bar-------------------
Signing with RIM Key.....
java.lang.NoClassDefFoundError: com/trustpoint/asn/AsnChoice
 at java.lang.Class.getDeclaredMethods0(Native Method)
 at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
 at java.lang.Class.getMethod0(Unknown Source)
 at java.lang.Class.getMethod(Unknown Source)
 at sun.launcher.LauncherHelper.getMainMethod(Unknown Source)
 at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)
Caused by: java.lang.ClassNotFoundException: com.trustpoint.asn.AsnChoice
 at java.net.URLClassLoader$1.run(Unknown Source)
 at java.net.URLClassLoader$1.run(Unknown Source)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.net.URLClassLoader.findClass(Unknown Source)
 at java.lang.ClassLoader.loadClass(Unknown Source)
 at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
 at java.lang.ClassLoader.loadClass(Unknown Source)
 ... 6 more
Exception in thread "main"
-------Completed in: 0 mins : 0 secs----------------

Batch Bar Signer process has ended in: 0 mins : 0 secs

Summary:
 Total number of unsigned bars found      = 1
 Total number of successfully signed bars = 0
 Total number of signing failed bars      = 1

Please give me answer its very urgent.

Thanks in advance.

 

BlackBerry Development Advisor
Posts: 15,885
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: BlackBerry Tablet OS Graphical Aid can't sign application

This is caused by a bug in the 1.5.0 Android packaging tools.  Upgrade to version 1.5.2 to fix the problem.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.