Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development

Reply
New Contributor
Posts: 5
Registered: ‎12-10-2012
My Device: Blackberry Playbook
My Carrier: N/A

Can't Find Repository when trying to install BlackBerry Plug-in for Android Development Tools

I'm trying to install the Blackberry Plug-in for Android Development Tools for Eclipse. I go to install new software, select https://bdsc.webapps.blackberry.com/android/downloads/eclipseplugin/ as the site I want to work with, select Blackberry Plug-in for Android Development Tools from the menu, click finish, and receive the following message.

 

An error occurred while collecting items to be installed
session context was:(profile=SDKProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: org.eclipse.update.feature,blackberry.tools.sdk.feature,1.4.0.201211081010
No repository found containing: osgi.bundle,com.qnx.tools.bbt.core,3.2.0.201211081010
No repository found containing: osgi.bundle,com.qnx.tools.bbt.ui,3.0.0.201211081010
No repository found containing: osgi.bundle,net.rim.ajde,1.4.0.201211081010
No repository found containing: org.eclipse.update.feature,net.rim.ajde.feature,1.4.0.201211081010

Has this bug been reported before or does anyone have some insight for me?

New Contributor
Posts: 2
Registered: ‎12-11-2012
My Device: Developer
My Carrier: not provided

Re: Can't Find Repository when trying to install BlackBerry Plug-in for Android Development Tools

Update the path in setting . 

Preference->install update->available software .

 

 

Change old path  to  "https://bdsc.webapps.blackberry.com/android/downloads/eclipseplugin/beta/Enabled"

 

New Contributor
Posts: 5
Registered: ‎12-10-2012
My Device: Blackberry Playbook
My Carrier: N/A

Re: Can't Find Repository when trying to install BlackBerry Plug-in for Android Development Tools

When I do that I get an error message saying "Could not find https://bdsc.webapps.blackberry.com/android/downloads"

New Contributor
Posts: 2
Registered: ‎12-11-2012
My Device: Developer
My Carrier: not provided

Re: Can't Find Repository when trying to install BlackBerry Plug-in for Android Development Tools

The error you are getting is a common eclipse error when there is one or more wrong  URL .

Maybe there is some typo .

 

The original error is because the update has different URL then original plugin It is in beta .

The new error you are getting is because may be you added a space while coping paste or something else I am not sure .

 

 

I will suggest please see the blackberry website as this url   it has detailed description .

Please edit  original bb  plugin path and change with new beta one from the above url .

If you didn't have adt v21 their is no point upgrading this .

 

You can work with your current bb installation but it will require old adt . The new one only make it work with adt v 21 .

New Contributor
Posts: 5
Registered: ‎12-10-2012
My Device: Blackberry Playbook
My Carrier: N/A

Re: Can't Find Repository when trying to install BlackBerry Plug-in for Android Development Tools

I just got it to install correctly. I'll make a new thread if something stupid happens later.