Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development

New Contributor
Posts: 3
Registered: ‎12-30-2011
My Device: playbook
My Carrier: no

Eclipse: No "Package Project" in Blackberry Tools

Trying to get this set up is getting really frustrating. Smiley Indifferent Eclipse for Java Indigo Service Release 1 build 20110916-0149 Android SDK with Android 2.3.3 SDK Platform 10 installed Android AVD manager installed (though I'm not going to use an Android VD, I'll be using my tablet) Blackberry Plugin for Android Developer Tools and Blackberry Tools SDK installed Target device is wifi playbook (in developer mode, connection tested OK) All signing keys are installed I've started a new workspace, and a new Android project. Right click on Project, chose Blackberry Tools, clicked Add Blackberry Nature to Project. Next, I try to do what the doc and the video says: Right click on Project chose Blackberry Tools, click "Package Project". But there is no option. There is just: Remove Blackberry Nature Verify APK Configure Targets Sign for App World If I click "Verify APK", I get a screen that says "Operation in Progess" for abut 1 second, then it goes away without any error messages. I have absolutely no idea what I've missed installing, but I'm half a second away from chucking this whole **bleep** thing and buying an iPad to develop on. =(
Posts: 1,280
Registered: ‎03-03-2011
My Device: Playbook, Z10, Q10, Z30 with Files & Folders and Orbit of course
My Carrier: Vodafone

Re: Eclipse: No "Package Project" in Blackberry Tools

Open Window > Show View > Other > General > Error log. Try again, and see if any errors appear there.


Files & Folders, the unified file & cloud manager for PlayBook and BB10 with SkyDrive, SugarSync, Box, Dropbox, Google Drive, Google Docs. Free 3-day trial! - Jon Webb - Innovatology - Utrecht, Netherlands
New Contributor
Posts: 3
Registered: ‎12-30-2011
My Device: playbook
My Carrier: no

Re: Eclipse: No "Package Project" in Blackberry Tools

[ Edited ]

Going to murder this playbook... I've uninstalled and reinstalled Eclipse multiple times. I've 100% ensured I have 2.3.3, r10, with the r15 version of the Android SDK (I found the download side for the R15 installer). I've tried both Wifi and USB to connect to the tablet. I've gotten up to "Add Nature", which works. But there's no Package Project.


I've tried instead "Sign for AppWorld". It builds the project, creates the apk, and creates the .bar file. If I right click on the BAR file and Run As...BlackBerry Android Launch:


1) The Android thing on the playbook launches

2) It gets up to Installing

3) It crashes at 57%, "Installing".


There is nothing in the error log. The details of the error are:


Failed to deploy project HelloAndroidUSB

Info: Sending request: Install

Info: Action: Install

Info: File size: 19116

Info: Installing ...

Info: Processing 19116 bytes

Info: Progress 50%...




result::failure -4





I have no idea what failure -4 means. I have no idea if the difference in actual_id and actual_dname mean anything. I took the apk and ran it through the online verifier, and it verifies just fine.


So WTF? Between all the shoddy and half-correct documentation, and now this, AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA!!!!!!!!!!!!!!!!!



New Contributor
Posts: 3
Registered: ‎12-30-2011
My Device: playbook
My Carrier: no

Re: Eclipse: No "Package Project" in Blackberry Tools

[ Edited ]

Wow, messed up the formatting in the previous post, will try to edit to fix. Also, AHHHHHHHHHH the stupid forum lost my post. One annoyance after another.


Anyways, MILD success. The (undocumented) ANDROID_HOME variable needs to be set. Here's how, at least for XP:


1) Right Click MY COMPUTER, Properties

2) Advanced, Environment Variables

3) Click NEW

4) Variable name is "ANDROID_HOME" (not quote, all uppercase)

5) Variable value is "C:\Program Files\Android\android-sdk"

  NOTE:  This is the default install location. It may be different on your machine. Pay attention when you install installer_r15-windows.exe.

6) Click OK, OK, OK

7) You might have to restart Eclipse


CAVEAT: I did some other unsuccessful changes. I don't think they matter. I hope not. Try this.


EDIT: I should note that there STILL is no "Package Project" in the Blackberry Tools context menu. Just Verify APK and Configure Targets. So I'm going to assume that the video and documentation are WRONG WRONG WRONG, based on outdated versions of tools that they never bothered to update the docs for. Like all the docs. How the heck are you supposed to attract developers when they have to spend three days discovering your docs are wrong and there's hidden settings that haven't been set?!?!?!?!?!?!?




New Contributor
Posts: 5
Registered: ‎02-03-2012
My Device: Torch 9810
My Carrier: Bell Mobility

Re: Eclipse: No "Package Project" in Blackberry Tools

I too was puzzled that it (the BB plug-in for ADT) wasn't automatically generating the BAR and I couldn't find an option in the Blackberry Tools menu to do it.


So, I guess "sign for AppWorld" is it.  It works for me - though it would be nice if build, package, install, and run could all be done with one keystroke (as with the ADT where I just hit ctrl-F11).