Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development

Reply
Developer
Posts: 121
Registered: ‎11-19-2008
My Device: Not Specified

Error message using online Android app signer for Playbook

I was able to previously use the online BAR signing tool and repackage my .apk for the Playbook, however when I try to re-sign a new version of my app I experience some problems.

 

I get an error message

"This APK was already packaged and signed, please update the APK’s version number to package again"

 

Does anyone know what this means?

 

I did try to increase the version of my app but to no avail.

 

 

Developer
Posts: 44
Registered: ‎03-20-2012
My Device: PlayBook
My Carrier: Telefonica Germany

Re: Error message using online Android app signer for Playbook

You have to increase the versionCode tag in manifest file.

In manifest you can define versionCode and versionName.

You have to increase VersionCode. As far as I know VersionName is not really interesting for the BAR signer.

 

For e.g.:

 

<manifest xmlns:android="http://schemas.android.com/apk/res/android"
    package="com.your.application"
    android:versionCode="1"
    android:versionName="1.0.0" >

 

 increasing version means it should be changed to

 

<manifest xmlns:android="http://schemas.android.com/apk/res/android"
    package="com.your.application"
    android:versionCode="2"
    android:versionName="1.0.1" >

 

Did you do this or did you only increased versionName?

_____________________________________________________
Someone helped you with a post or solved your problem? Click on *Like* of his/her post or mark it as solution.
Thank you Smiley Wink
Developer
Posts: 236
Registered: ‎07-27-2012
My Device: BlaclBerry PlayBook 16gb, BlackBerry dev alpha
My Carrier: Airtel

Re: Error message using online Android app signer for Playbook

increase the version of the apk. Increase it to other then 1.0.. keep 1.0.1 or 1.1. i am sure it will resign your app