Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Developer
Posts: 271
Registered: ‎12-24-2010
My Device: BlackBerry 10
My Carrier: Airtel

For Android Runtime, is Eclipse 3.8 is must required??

Hi,

 

I have Eclipse 3.6 installed with Android Plugins. For Android Run time, we require 3.8 as mentioned in documentation. But while upgradation of the eclipse, i am getting error. So my question is, Only 3.8 version will work for Android runtime??

 

Thanks..

Developer
Posts: 648
Registered: ‎09-26-2012
My Device: Limited Edition Z10, Playbook 16GB/32GB, Dev Alpha A/B/C
My Carrier: Mobile Vikings

Re: For Android Runtime, is Eclipse 3.8 is must required??

Though this is not a real answer to your question: what have you done to receive the error? If you just follow the steps mentioned in this step by step guide I think not a lot can go wrong. And if you've followed these steps, you will have the latest version of Eclipse, which will be sufficient for further development of your Android apps.

 

Just try the step by step guide, and if you still have errors, maybe wonder why you are receiving the errors.



A like is always appreciated,
but a nomination for BB Elite even more :-)
You can also contact me on Twitter: @ndsmyter
Highlighted
Regular Contributor
Posts: 84
Registered: ‎01-31-2013
My Device: Simulator !!!
My Carrier: 8608800458

Re: For Android Runtime, is Eclipse 3.8 is must required??

You'll get an error in 3.6 during deployment/install due to some new method that is not in 3.6, but I upgraded to 3.7 (indigo) and then it worked.