Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Highlighted
Regular Contributor
Posts: 60
Registered: ‎12-19-2012
My Device: BB10 Alpha B
My Carrier: SFR
Accepted Solution

Google Maps API v2

Hi !

 

As Google just released its new Google Maps API, I wondered if it was compatible with Blackberry 10.

 

Thanks

Contributor
Posts: 16
Registered: ‎01-16-2013
My Device: BB10 Dev Alpha
My Carrier: Free

Re: Google Maps API v2

I'm not really an expert, but http://developer.blackberry.com/android/apisupport/unsupportedapi_blackberry10_software_features.htm... lists the whole com.google.android.maps package as "unsupported", so I guess Google Maps API v2 won't be available.

Regular Contributor
Posts: 60
Registered: ‎12-19-2012
My Device: BB10 Alpha B
My Carrier: SFR

Re: Google Maps API v2

As described here, http://developer.android.com/google/play-services/setup.html Maps V2 heavily relies on Google Play Services APK, which I am pretty sure BB10 doesn't have.

Contributor
Posts: 31
Registered: ‎08-25-2012
My Device: Torch 9800
My Carrier: none

Re: Google Maps API v2

No google maps android Api v2 is not supported by BB 10. Use google maps javascript Api v3 in webworks platform.

Contributor
Posts: 16
Registered: ‎01-16-2013
My Device: BB10 Dev Alpha
My Carrier: Free

Re: Google Maps API v2

"Use google maps javascript Api v3 in webworks platform" => So that means no solution for Android Runtime Development ?