Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development

Reply
Developer
Posts: 21
Registered: ‎07-16-2012
My Device: Playbook, Z10, Z30
My Carrier: Rogers
Accepted Solution

Help! Can't submit package due to version issue

I'm getting the following error message in the vendor portal.

 

  • The package version in your .bar manifest file for Release 1.0.134 must be greater than the previous version, but lower than any the next release version added to the vendor portal. Your .bar manifest file package version must be greater than 1.0.133 but less than 1.10. Correct your .bar manifest file and try again to continue.

 

My bundle version is 1.0.134 and the fact it allowed itself to be signed indicates it was not the prior version.

The current version in BBRY World is 1.0.133.

 

Now here is where it gets weird.

Sideloaded my new build on one Z10 running 10.1 and it shows as version 1.0.134

Sideloaded it on another Z10 running 10.2 and it shows as version 1.0.133  WTH????

 

I am running against a tight schedule to get this submitted as its a transit app and the current one will not be responsive after Sept 1 due to the new fall schedule. 

Developer
Posts: 21
Registered: ‎07-16-2012
My Device: Playbook, Z10, Z30
My Carrier: Rogers

Re: Help! Can't submit package due to version issue

More details.

 

Opened the MANIFEST.MF file in the bar and found the following.

 

Archive-Manifest-Version: 1.2
Archive-Created-By: BlackBerry BAR Packager v1.4
Package-Version: 1.0.134.0
Application-Version: 1.0.134.0

 

Trusted Contributor
Posts: 160
Registered: ‎11-17-2010
My Device: PlayBook, Z10, Q10

Re: Help! Can't submit package due to version issue

Hi,

 

I think you need to increment field "android:versionCode" in your AndroidManifest file.

The version-name or application-version fields are treated more like string.

--
If you find this post useful please Like it.
If it solves your problem please mark as solution.
Developer
Posts: 21
Registered: ‎07-16-2012
My Device: Playbook, Z10, Z30
My Carrier: Rogers

Re: Help! Can't submit package due to version issue

I did and it follows a a pattern of incrementing previous releases, but this one is being rejected with an error that doesn't makes sense since the code signing process would have caught an issue with the release version.

 

Blackberry World Vendor support is being tardy with answering my ticket so this is not going well.

Trusted Contributor
Posts: 160
Registered: ‎11-17-2010
My Device: PlayBook, Z10, Q10

Re: Help! Can't submit package due to version issue

[ Edited ]

Did you eventually try to further increment the versionCode (and maybe the version numbers)? And then submit again. I mean the numbers doesn't have to exactly follow the previous release just be higher.

 

Do you convert your apk with the online packager or do you build it locally?

--
If you find this post useful please Like it.
If it solves your problem please mark as solution.
Developer
Posts: 21
Registered: ‎07-16-2012
My Device: Playbook, Z10, Z30
My Carrier: Rogers

Re: Help! Can't submit package due to version issue

I will try another release number today but I was hoping for some response from Blackberry World Vendor support before I started burning through release version numbers. Total fail on BBRY end to be tardy with vendor support replies.

 

I used the Blackberry Graphical Aid tool on my PC which I believe is just a front end for the command line tools.

Developer
Posts: 21
Registered: ‎07-16-2012
My Device: Playbook, Z10, Z30
My Carrier: Rogers

Re: Help! Can't submit package due to version issue

Well I've burned a few release numbers via signing and none of them are getting past the issue mentioned above. Has anyone submitted a release lately to BBRY World?

Contributor
Posts: 47
Registered: ‎08-06-2012
My Device: Passport and Z10
My Carrier: Rogers / Thunder Bay Tel

Re: Help! Can't submit package due to version issue

I'm having the same problem when trying update one of my apps.

The full error message doesn't make any sense

"The package version in your .bar manifest file for signals_playbook must be greater than the previous version, but lower than any the next release version added to the vendor portal. Your .bar manifest file package version must be greater than 3.0. Correct your .bar manifest file and try again to continue. "

In my case I have set and confirmed that the bar package version is 3.1. I've spent the last several evenings trying to figure this out.

What did BlackBerry changed in the past month or so?

I did submit this problem to dev support and haven't heard anything from them. I'm also on a deadline to fix something.

 

Highlighted
Developer
Posts: 21
Registered: ‎07-16-2012
My Device: Playbook, Z10, Z30
My Carrier: Rogers

Re: Help! Can't submit package due to version issue

My error message stated that my version # must be between 2 ranges as I had an old draft submission with an inexplicable higher number. Support said they deleted the draft submission with the higher number and now everything should be OK. Since they had my bar file they submitted it for me, so I have no way yet of knowing if all my problems are behind me.