Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development

Reply
Developer
Posts: 1,006
Registered: ‎05-22-2009
My Device: Not Specified

How to debug the application in BB 10 Android App thr Eclipse

Hi,

 

I am trying to port the android app to BB 10 application,While trying to debug the application,I am option of getting Force Close only,I am not able to debug,but app get installed .i close the application and open it ,but it is not debugging Can i know how to debug the application thr Eclipse?

 

 

Thanks Rakesh

Developer
Posts: 571
Registered: ‎04-11-2009
My Device: BB 10 Dev Alpha

Re: How to debug the application in BB 10 Android App thr Eclipse

From where you are installing the App. Do run it from Eclipse -> Debug as Blackberry Android Launch. Now you can see the adb logs here..

Regards,
Kanak Sony
------------------------------------------------------------------------------------------
http://dodevelopnshare.wordpress.com/ | http://www.linkedin.com/profile/view?id=188131481&trk=tab_pro
Developer
Posts: 1,006
Registered: ‎05-22-2009
My Device: Not Specified

Re: How to debug the application in BB 10 Android App thr Eclipse

[ Edited ]

I am getting logcat ,and i am seeing it (SOPs),I am not able to identify the root cause of exception .

 

I  am using 4.2.2. and in Z10 ,I am not getting any issue in one functionality ,But in Q5,I am getting app crashes like below

 

AndroidRuntime(25321694): java.lang.RuntimeException: Unable to pause activity {com.xxx/xxxxxxxxx}: android.view.WindowManager$BadTokenException: Unable to add window -- token null is not valid; is your activity running?

 

 

you have any idea why it is happening?It happens when  i click ok of AlertDailog

 

Thanks

Rakesh

Developer
Posts: 1,006
Registered: ‎05-22-2009
My Device: Not Specified

Re: How to debug the application in BB 10 Android App thr Eclipse

Hi ,

 

I am not getting this issue due to Display Alert,But on when launching intent ,I am getting this error which happens on Q 5 device,But not on z10 device.

 

Thanks

Rakesh