Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development

New Contributor
Posts: 8
Registered: ‎05-09-2012
My Device: Playbook
My Carrier: None

How to get ADB to see Playbook?

Had everything working perfectly. Uploaded my app and worked fine. In the same Eclipse session without any hardware or configuration changes, it stopped working and the Playbook hasn't been seen by ADB since. Mass storage is still seen and requires password when USB attached, so the connection is valid. Items I've tried so far include:
Rebooting system
Rebooting Playbook
Disconnection/Reconnection of USB cable
Confirmed Playbook in debug mode

Renewed debug token
Playbook Debug's first  "IP adreesses" matches the Eclipse's Preferences, Blackberry, Blackberry Tooks SDK, Targets, Device IP.

Confirmed app is set to Android 2.3.3


In all cases, DDMS shows no devices, and at a command prompt, "ADB devices" does not show any devices when the Playbook is connected and on. Of course, selecting in Eclipse "run" will only run the Android simulator (or if run configuration's target is set to:manual, there are no options to run on a device).


System is Windows 7 x64 with latest updates from Microsoft and Google SDK manager. Playbook OS version


Any ideas on what else I can dry to get the Playbook to work with ADB/Eclispe again?