Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Highlighted
New Member
Posts: 1
Registered: ‎03-07-2012
My Device: Play Book
My Carrier: Starhub
Accepted Solution

How to increase application version number in Android runtime eclipse plugin

I am using BlackBerry Android runtime eclipse plugin to code sign my application. It is successful first time, later I changed some code and code sign it again and get error


Error: Code signing request failed because this file has been previously signed.    <MyApp>.bar    /<MyWorkspace>/dist/Android 2.3.1   <MyWorkspace>\<MyApp>.bar    BlackBerry Previously Signed

 

Then I read some post in this forum and find some version number in <MyApp>.xml need to be increased to solve my error, but I cannot find such a file and the version number in the eclipse project. It would be appreciate if someone can tell me how to increase version number in a project created by BlackBerry Android runtime eclipse plugin.

Contributor
Posts: 21
Registered: ‎03-07-2012
My Device: Developer
My Carrier: T-Mobile

Re: How to increase application version number in Android runtime eclipse plugin

You need to edit the AndroidManifest.xml file that you'll find in the root of the project in Eclipse.

Just increase the versionCode parameter by 1.

 

http://developer.android.com/guide/publishing/versioning.html