Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development

Posts: 112
Registered: ‎10-08-2012
My Device: Playbook, Bold 9790, Z10
My Carrier: Vodafone

Issues when editing apk using Eclipcs!!!

Hello guys,,


I have an apk which i want to edit & convert  to bar, I am new to Eclips, & now am trying to edit one of my apk file using eclips, what i did was, I extracted the apk using apk tool & then i imported the same as an existing project to eclips & started working on it, & made changes then i repacked apk & signed & installed on an android device, it was not working, was showing message says, process stopped working, when i converted to bar, the same wsa happening on my playbook.


Then i checked it in other way to findout wtr i did some mistake on my apk file, that caused this problem, 

I simply opened the same extracted apk(using apktool) &as an existing project on eclipcs,  i didnt do anything on the file, simply repacked & signed & tried installing on an android device sitll same, getting message says process stoped working.  


Then i tried the same on other apk, this time i simply imported that extracted apk & tried to run on the build in simulator on eclips, it also showed the same message, but if i install that app without importing to eclips it work fine on both android & playbook...can some one help me with this, is tre anything wrong in the way how am extracting the apk, or something wrong with eclipcs..