Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development

Reply
New Contributor
Posts: 6
Registered: ‎06-18-2013
My Device: Simulator
My Carrier: Rogers

MinSDK required level 10 for JellyBean runtime

Hey gang,

 

I'm trying to package an Android app designed to run on handsets (no tablets) for Android OS 4.0.3 and higher (SDK 15+). The issue I currently seem to be running into is that when verifying the APK I get the error:


minsdkVersion: 15 is higher than 10:required minimal Tablet OS version=10.2 

 

SDK 10 is for Gingerbread. Now my understanding is that the new runtime (beta i know) should work with JellyBean. 

 

The error only states Tablet OS (which I'm not interested in anyway).

 

Do I need to specify somewhere that I don't want Tablet OS support? Or is this a generic error indicating that even though I'm targeting SDK 17 I still need to have my minSDK as version 10? Which would be a little lame.

 

 

Retired
Posts: 264
Registered: ‎01-08-2013
My Device: BlackBerry 10 Dev Alpha B
My Carrier: Bell

Re: MinSDK required level 10 for JellyBean runtime

[ Edited ]

This is just a warning to let you know that if you were to deploy it to a Tablet OS, that Tablet would need OS version 10.2 for it to work properly.

 

If you don't plan to deploy to a Tablet device, you should be fine.

 

Smiley Happy

 

    Justin

Justin Jasmann | Android Application Development Consultant
Developer Relations
developer.blackberry.com
New Contributor
Posts: 6
Registered: ‎06-18-2013
My Device: Simulator
My Carrier: Rogers

Re: MinSDK required level 10 for JellyBean runtime

It actually gives a warning and an error but you're right it still worked. The only catch was that I had to delete the error manually.  Thanks for the quick help.

Retired
Posts: 264
Registered: ‎01-08-2013
My Device: BlackBerry 10 Dev Alpha B
My Carrier: Bell

Re: MinSDK required level 10 for JellyBean runtime

Anytime! Thanks for accepting the solution as well Smiley Wink

 

    Justin

Justin Jasmann | Android Application Development Consultant
Developer Relations
developer.blackberry.com
New Contributor
Posts: 6
Registered: ‎06-18-2013
My Device: Simulator
My Carrier: Rogers

Re: MinSDK required level 10 for JellyBean runtime

Actually I think I spoke too soon. I still had to drop the minSDK down to 10 before it would actually launch. Now it launches but I'm getting errors and warnings around Fragments. It really feels like the plugin is configured to Gingerbread.

Retired
Posts: 264
Registered: ‎01-08-2013
My Device: BlackBerry 10 Dev Alpha B
My Carrier: Bell

Re: MinSDK required level 10 for JellyBean runtime

Is this the plugin for Eclipse? Updated to 1.6?

 

    Justin

Justin Jasmann | Android Application Development Consultant
Developer Relations
developer.blackberry.com
New Contributor
Posts: 6
Registered: ‎06-18-2013
My Device: Simulator
My Carrier: Rogers

Re: MinSDK required level 10 for JellyBean runtime

Yes and yes. I also tried it with the command line tools and had the same minSDK error. 

Retired
Posts: 264
Registered: ‎01-08-2013
My Device: BlackBerry 10 Dev Alpha B
My Carrier: Bell

Re: MinSDK required level 10 for JellyBean runtime

Well that's odd. 

 

In Eclipse, you may need to do set your build target if you haven't already:

 

Right-click on your project -> Properties -> BlackBerry -> Minimum OS Version 10.2.

 

I'm not sure why the 1.6 Command-line tools would output that though. Can you post your WRN?

 

    Justin

 

 

Justin Jasmann | Android Application Development Consultant
Developer Relations
developer.blackberry.com
New Contributor
Posts: 6
Registered: ‎06-18-2013
My Device: Simulator
My Carrier: Rogers

Re: MinSDK required level 10 for JellyBean runtime

Okay that seems to have done the trick. I must have missed a parameter when running the command line tool.

 Thanks

New Contributor
Posts: 6
Registered: ‎06-18-2013
My Device: Simulator
My Carrier: Rogers

Re: MinSDK required level 10 for JellyBean runtime

GAH this is frustrating. Changing the build target in eclipse seemed like it worked as i wouldn't get any validation errors at all when i verified the APK. Which seems right. 

 

However, now when I try to run the project I get a different error that says 

result::failure -12

Which, I've found means that the app isn't supporting Gingerbread. So basically the same issue I had before.